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Tutorial 1 – Introducing ModelVision 

Introduction  

The purpose of this tutorial is to provide an overview of ModelVision. Subsequent tutorials 
illustrate basic and advanced features available in the software.  

This tutorial concentrates on the import and display of geophysical data in ModelVision. It is 
recommended that this tutorial be reviewed briefly, and then progress onto other tutorials 
that address more advanced topics. 

Within the tutorials are individual sections on: 

• How to use the tutorials  

• Import of data and supported formats  

• Displaying data in a variety of forms and how to control the displays 

• Development of basic models  

• Advanced modelling  

• Regional and residual design and manipulation 

• Inversion and its uses 

• Use of AutoMag 

Aim 

This tutorial is aimed at providing an overview of ModelVision and presenting the concepts 
associated with importing and displaying geophysical data. A number of basic import data 
formats are supported for single and multiple line types and these are presented with 
examples. Additional import descriptions are given for grid, point and borehole datasets. 

Intended User Level 

This tutorial is intended for viewing by beginners and inexperienced users to provide an 
overview for interested parties and a good refresher for experienced users who have not 
used ModelVision for some time. 

ModelVision Overview 

ModelVision is a geophysical modelling package for the display, analysis and modelling of 
magnetics and gravity data. ModelVision provides a powerful suite of data display tools for 
maps and cross-sections. These views enable you to visualize your models in the context of 
field data. You can import other data sets such as drillhole logs, radiometrics, basement 
surfaces, terrain and vector graphics for visualization in the modelling context. 

Models include conventional body types such as dykes, tabular, polygons, spheres, 
ellipsoids and cylinders. Complex 3D faceted shapes can be built from cross-section and 
map views. This combination of shapes allows discrete anomalies to be analyzed as simple 
mineral exploration targets or modelling of basins for petroleum exploration. Bodies can be 
combined to build complex models such as intrusions within a layered environment. 

With the synthetic survey option you can create an atlas of magnetic profiles and maps to 
simulate expected responses. These atlases can be used for pre-survey planning or 
assistance in the interpretation process. 
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Generalized geophysical inversion allows you to optimize forward model solutions without 
spending large amounts of time on what is normally regarded as minor geological 
refinement. If you have physical property constraints or drillhole control, you can use 
inversion to better define the shape of a particular anomalous source. 

The concept of In-line filters allows you to look at your data and model results through the 
same filter. A first vertical derivative filter is used to better separate overlapping anomalies 
and assist with the removal of the regional magnetic field. Significant improvements in depth 
accuracy can be expected with this technique. In noisy areas of laterite, an in-line upward 
continuation filter can be used to help reduce the noise.  

When examining your models in a map view, you can enable a range of display types such 
as images, contours, stacked profiles, grid profiles, sample points, drillholes and vector 
graphic files. Cross-section views are used to produce detailed depth sections where you 
can simultaneously model gravity and magnetic data, display drillholes, plot individual and 
composite body responses, turn on in-line filters and display topography. Map and section 
views can be plotted to scale or at A4 presentation scale. A simple perspective presentation 
is included for the display of models and drillhole data. 

Regional magnetic and gravity fields can be implemented on individual profiles or as two 
dimensional polynomial surfaces. These surfaces are supported directly in the modelling and 
can be used as a tool for simple regional-residual separation. 

Line oriented convolution and FFT filters are implemented for standard geophysical tasks. 
These help to analyze the information content of your data prior to modelling. A powerful 
multi-channel display option is included to help with the visualization of the filter output. You 
can use this tool to zoom and pan long lines of data. A set of 2D convolution filters 
compatible with the ER Mapper image processing system are also included. 

Useful utilities such as gridding, synthetic surveys, traverse extraction, channel calculator, 
interpolation, data maintenance, statistics and reporting provide a well rounded environment 
for the geophysical interpreter. Grids of virtually any size can be computed from either point 
or line data. The calculator interface provides a simple visualization for manipulation of 
channel data in line, point, grid and drillhole data sets. You can also use it to sample gravity 
survey grid data onto aeromagnetic flight lines. 

A CAD tool (Layout Window) is included that allows you to layout your interpretation in a 
composite view. You can add interpretive information as overlays to any of the standard 
views. A comprehensive suite of drawing and annotation tools allow you to produce 
professional interpretation displays for inclusion in your reports. Use any size page that is 
supported by your printer or plotter. 

You can import data from a variety of data standards such as ER Mapper, Geosoft, ASEG-
GXF or use the external data base link option to design direct links to your in-house 
database system. Similarly you can export your profile and grid data in a variety of industry 
standard formats.  

Project Definitions 

ModelVision uses projects to manage various analysis exercises and a file called 
MVPROJ.INI records your entries for later use. Initially, a project is required to define the 
various properties of the data. Binary session files (.SES) can also be used to store data, 
models and displays if required.  

Project files contain information relating to: 

• Data projection, datum and spheroid 

• Location of the project (a project folder) 

• Magnetic field information for modelling 

• Units to be used 
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• Default information regarding models and displays 

• Project description information 

Select the File>New>Project option and enter the information as required. As an example, 
assume the required parameters are as below: 

 Datum:  Australian Geodetic Datum 1966 (AGD66) 
 Projection: Transverse Mercator 
 Zone:  AMG Zone 54 (TMAMG54) 

 

Note that the entries for the Earth’s magnetic field are set to be: 

Field Intensity : 58667 
Inclination: -66.4 degrees 
Declination: 12.7 degrees East 

Once a project is defined in ModelVision, it is then possible to import line, grid, point or 
drillhole data. 

Importing Data into ModelVision 

ModelVision can import the following data types: 

• Binary session files of saved data (program snapshots) 

• ASCII profile data 

• ASCII point data 

• ASCII drillhole data 

• Grids of various formats 

• External data from databases (e.g. Geosoft, Intrepid etc) 
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ASCII data to be manipulated, displayed and modelled can be loaded by the File>Import 
option. Selection of this option displays a second menu list containing ASCII formats and 
other possible sources of data. This list for survey lines is shown in the following screen: 

 

ModelVision can import ASCII line oriented and point based data. Grid files, drillhole data 
and information held in databases or external software programs can also be imported. 

Profile Data 

Eight ASCII line oriented data file types are available for import. These fall into the following 
two categories: 

Single line – Files that contain multi-column data but with columns relating to only one 
profile or traverse. 

Multi line – Combined traverses of multi-column data can be read using this style of input. A 
number of standard file formats are available and suitable for importing into ModelVision. 

Single-line formats 

File types that contain data from single data traverses and are supported by ModelVision 
include: 

• TOOLKIT format files 

• Geosoft single format files 

• ER Mapper ASCII traverse files 

Data contained in these formats have one or more header lines followed by data records. 
Usually the header record(s) contains information about the line name, data columns or title 
text. The data records may be formed by a number of columns that contain the location and 
variable channels of input data. The various data values may lie one under the other for each 
record or, depending on the format, the values may be placed in any column of the record 
provided their order is maintained. 

Multi-line formats 

Combined traverses of multi-column data can be read using this style of input. A number of 
standard file formats are available and suitable for importing into ModelVision. Supported 
Multi-Line data file formats include the following: 

• Simple XYZ Encom line format (LIN) 
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• XYZ line format but with a separate header (LIN and HDR) 

• Multi line Geosoft XYZ file (XYZ) 

These data formats, similarly to the single line formats, may have descriptive header records 
followed by data arranged in column or open format. Alternatively, in the case of the multi-
column dataset with no header, an external header can be used. 

Drillhole Data 

Downhole data can be imported into ModelVision by reading a file that contains X, Y and Z 
data location coordinates plus sensor channels. The X and Y coordinates refer to horizontal 
positioning as for a conventional line oriented dataset and the Z data contains depth 
information beneath a nominated datum. The default sense of direction is positive down for 
increasing depth.   

Point Data 

Certain data collection procedures acquire data at random locations. Examples of this are 
regional gravity surveys or geochemical assaying projects. With these data types there are 
no line-related methods of collating the data and so each record of the input data file is dealt 
with individually. There is a requirement that point data sets have an associated number 
similar to the line specification. This number is referred to as a ‘point set identifier’ and is 
used to associate records with similar properties (for example, gravity datasets, gold assay 
datasets, magnetic solution points etc). The input data type is of a definable XYZ format 
where the X and Y coordinates specify the easting and northing location of the sample point. 
A number of Z channels corresponding to measurements at each sample location can be 
loaded.  

Grid Import 

ModelVision is capable of importing various grid formats, some of that are written in ASCII 
although most are in binary. In most grid formats, the first few lines of the file are assigned to 
a header. The header contains information relating to origin, extent, numbers of rows and 
columns, grid mesh size, rotation etc. 

ModelVision supports the following grid formats: 

• Encom 

• ER Mapper (ERS and image BIL file - Versions 3.x, 4.x and 5.x) 

• INTREPID (similar to ER Mapper grids) 

• Geosoft binary grid format 

• ASEG GXF format 

• Geopak binary grid 

• USGS binary grid format. 

Displaying Data in ModelVision 

ModelVision displays data in Map, cross-section, 3D and graph formats selected from the 
View menu.  When you first load line, point or grid data into ModelVision it will open a view of 
the data for you. 
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Multi-track is the only view that does not display the model, as it is used for general multi-
channel data presentation. Each view is opened in a separate window and you can have 
multiple views of the same type. A change that is made to a body in one window will be 
reflected in other views. For example, if a tabular body is shifted in a profile cross-section it 
will also shift along the line of section in any map view. 

The stacked profile, contour and grid profile display formats are map presentations. These 
formats allow both data and models to be shown together for interactive modelling. The X-
section display format allows data channels plus a cross-section of the modelled bodies to 
be displayed. 

In each of the model display windows, bodies created and edited are shown in their correct 
geographic location and orientation. As editing functions are performed, other model display 
windows are updated to reflect the changes.  

The individual presentation formats available are described below. With each presentation 
format is an interactive tutorial associated with a dataset. To run the tutorial, execute 
ModelVision and then import and present the data using this display format. 

New Layout 

A new Print Layout can be displayed using this menu option which allows you to organize 
your active map, x-section or perspective display windows into a report style with titles and 
captions. 

Multi-Track 

Multi-channel display windows are available to display data channels imported into or 
created in ModelVision. Many options are available to control display attributes. 

X-Section 

Model cross-section and data display of magnetic or gravity channels. Additional channels 
such as residual or elevation tracks can be included in the displayed tracks. 

Perspective 

A perspective view of models created in model windows. 

Map>Stacked Profile 

A map view where the selected data channels are displayed for all loaded lines. 

Map>Points  

A map view of points representing measurement location not contrained to lines. 

Map>Contour 

A contour map view of a ModelVision grid or an imported grid. 
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Map>Grid Profiles 

A stacked profile map view of a grid. The data is derived from the grid as a series of column 
or row stacked profiles. This presentation is useful for modelling purposes and is very fast to 
display. 

Map>Grid Images 

A basic image display of a selected grid of data. Sun angle enhancement can be applied to 
highlight anomalies. Image presentations are always presented first in map displays with 
vector style displays drawn onto the image. 

Multi-Track Display 

Multi-channel display windows are available to display data channels imported into or 
created by ModelVision. Many options are available to control display attributes. 

Note Throughout the tutorials you will be required to load certain datasets. If you are 
running an unlicensed or evaluation version of ModelVision, this will not be 
possible as this function is disabled for demonstration purposes. You will, 
however, be able to use the File>Open option and load an equivalent dataset 
from a .SES (binary) project file. If for example TUTE.TK is required, there will be 
a TUTE1.SES file that can be loaded with the File>Open option to import the 
data. 

 

Tutorial Procedure 

For this part of the tutorial, you will investigate both importing and display of loaded data into 
a Multi-track display. For this exercise the data file TUTE1.TK will be used. This data file is 
similar to that shown below: 

Line 45670N Bodalla West (1987) 
EAST NRTH FID MAG K U TH 
442420.0 7829846.0 7864.0 2008.29 86.80 23.90 41.80 
442419.9 7829855.0 7863.0 2008.42 86.80 23.90 41.80 
442419.8 7829864.0 7862.0 2008.54 86.80 23.90 41.80 
442419.6 7829872.0 7861.0 2008.67 86.80 23.90 41.80 
442419.5 7829881.0 7860.0 2008.81 86.80 23.90 41.80 
442419.4 7829890.0 7859.0 2008.95 86.80 23.90 41.80 
442419.3 7829899.0 7858.0 2009.09 86.80 23.90 41.80 
442419.1 7829907.0 7857.0 2009.23 86.80 23.90 41.80 
442419.0 7829916.0 7856.0 2009.37 64.90 12.00 47.70 
442419.0 7829926.0 7855.0 2009.52 64.90 12.00 47.70 
442419.0 7829936.0 7854.0 2009.66 64.90 12.00 47.70 
442419.0 7829946.0 7853.0 2009.82 64.90 12.00 47.70 
442419.0 7829956.0 7852.0 2009.96 64.90 12.00 47.70 
442419.0 7829966.0 7851.0 2010.11 64.90 12.00 47.70 
442419.0 7829976.0 7850.0 2010.23 64.90 12.00 47.70 
442419.0 7829986.0 7849.0 2010.34 64.90 12.00 47.70 
442419.0 7829996.0 7848.0 2010.42 52.50 24.90 20.40 
442419.0 7830004.0 7847.0 2010.48 52.50 24.90 20.40 
442419.0 7830011.0 7846.0 2010.54 52.50 24.90 20.40 
442419.0 7830019.0 7845.0 2010.59 52.50  24.90 20.40 

 



 ModelVision Tutorials 10 

Step 1 

Use the File>Open>Project menu option to open the project file for this tutorial located in: 
..\TUTORIAL\TUTE1  

Using the File>Import>Profile>Toolkit Format menu option import the file TUTE1.TK 
(located in the same folder as the project file). This single line of data has been extracted 
from a typical airborne survey and is a sequential line file containing 1999 data records. 
Contained in the file are AMG coordinates, Fiducials, Magnetics and the spectrometer 
channels of Potassium (K), Uranium (U) and Thorium (Th). 

The aim of this exercise is to present the data in various forms and to illustrate the ease with 
that various relationships between multi-channel information can be derived. The following 
tasks should be undertaken to make you familiar with analysis of this type of data. 

Step 2 

After loading, the line data statistics dialog will appear which can be manually accessed via 
the Utility>Statistics>Line Data menu option. This dialog shows you line extents, channels 
ranges etc. Note that a distance (DIST_ABS) column has been computed automatically from 
the northing and easting data. This channel is used as the horizontal scale for plotting and 
display purposes. 

 

When you close the statistics dialog, you will be given the option to display selected 
channels in a stacked profile map.  This is useful when loading a full survey, but not pertinent 
for a single line of data.  Cancel this option and go to the next step. 

Step 3 

Display the magnetics and radiometrics using the View>Multi-Track menu option to check 
the integrity of the data. Activate the Reference track check box to allow the data in the 
reference track to be scrolled, zoomed and panned.  
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When the channels are selected the profile will be displayed. Experiment with the Zoom 
In/Zoom Out and Pan toolbar options on one of the channel tracks before returning the track 
to its full size by positioning the cursor over one of the tracks and clicking the right mouse 
button to display the pop-up menu options. Select the Fit Track>Horizontal option to adjust 
the appearance of the track. 

Step 4 

Position the cursor in the Th (Thorium) track and click the right button. A pop-up menu will 
appear with various options available including the Configuration utility. Select this option 
and a new dialog called the Track Configuration will appear which controls the display 
attributes of tracks. This dialog can be used to add a new curve to a track. The Add Curve 
option is also available in the track pop-up menu.   

 

 



 ModelVision Tutorials 12 

Use the Add Curve button to add a second channel of Magnetics. 

 

Step 5 

To modify the appearance of the traces in each track, place the cursor in the left hand 
‘curve-name’ box of the original MAG track and double click the left mouse button. A 
configuration dialog will appear as below. 

 

Modify the various options as required. Remember that the modifications being made apply 
only to the selected curve. The fill or trace colour can be altered using the dialog. 

To display the station positions along each track activate the Symbols check box on this 
Channel Edit dialog and select the Symbol button to specify the appearance of the symbols. 
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Also within this dialog the above and below colours for the profiles can be altered as can 
scaling of the various channels. 

You may wish to experiment with some of the other settings controlling the display of the 
curves. Remember also that you can ‘drag-and-drop’ curves from one track to another and 
resize the tracks to enlarge one track over another. 

Zooming, scrolling and panning are controlled by the Reference track (the greyed track at 
the base of the display), the scroll bar across the bottom and the Fit button on the Display 
toolbar. Zooming in to an area on the reference track will resize the other tracks in the 
display to this zoomed area but the reference track will remain at the original scale with the 
zoomed area highlighted.  

 

Place the cursor in the Reference Track and click the right mouse button to display the Fit 
Track pop-up menu item. This option allows the track to be fitted in both vertical and 
horizontal directions. 

Clearing Memory and Data 

When you are finished processing or interpreting a dataset in ModelVision, you can save the 
data, display formats etc in a binary session file (use the File>Save or Save As... options). 
This operation saves a project but it does not clear memory, data and models etc. To clear 
the memory and reset defaults to prepare for a new dataset, use the File>Close or 
File>New option. 

Display a Cross-Section 

This part of the tutorial involves loading a multi-line dataset and displaying a selected line as 
a cross-section. Cross-sections (referred to in this reference manual and the software as “x-
sections”) are used primarily for modelling (either gravity or magnetics). 

Step 6 

Import the file TUTE.HDR (located in the ..\TUTORIAL\TUTE1 folder) and use the 
File>Import>Profiles>Sep. Header (HDR + LIN) option. This import style is used for large 
data files where it is not desirable to edit the data file, but simply to create a Header file that 
describes the contents of the columns of the data. As an example of this format, examine the 
TUTE.HDR and TUTE.LIN files in an editor.  

Note If ModelVision is running in Demonstration Mode, import the file TUTE1.SES 
using the File>Open>Session option. 
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Step 7 

Once the data has been imported, examine the statistics in the Line Data Statistics dialog 
which automatically appears. To open this dialog at any other time in ModelVision use the 
Utility>Statistics>Line Data menu option. 

 

Step 8 

Prior to starting modelling, you need to provide ModelVision with information about the 
channels that will be used to define the sensor type(s) and sensor location. Use the 
Model>Line Control menu option to open the modelling control dialog. Turn on the Model 
Magnetics and Use Regional check boxes magnetic data input channel is set to MAG and 
the Sensor Z Channel is ALT.  

 

Click on the Select Lines button in the Line Control dialog and activate Line 1500 for 
modelling.  
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Now activate the Use Regional tick box and select the Compute Regional button in the Line 
Control dialog to access the regional setup (see below).  Select the Active Lines button and 
select all lines available in the list for the regional. Make sure that the regional Order is set to 
1, then select the Compute from Data option.  This fits a first order polynomial (slant line) to 
the data.  This line will be too high for normal modelling and you will need to apply a manual 
adjustment to the level using the fix points that will be visible in the cross-section view. 

You can experiment with the polynomial order and you will see the formula and coefficient 
fields change each time.  You need to select Compute from Data each time you change the 
polynomial Order. 

Note that you must activate the regional for each line you wish to model with a cross-section, 
but this can be done each time you wish to activate a new line.  You can also compute 
regionals for lines that are not modelled.  In this exercise we will only model the one line. 

 

Step 9 

Use the View>X-Section menu option to select Line 1500 and ensure that the Model 
Magnetics, Display Input Channel, Display Elevation Channel and Display Regional check 
boxes are selected. 

 

Once the cross-section is displayed, a profile will be shown with observed data in the top 
track and a ‘slice’ vertically through the earth beneath. This lower track represents a cross-
section of the subsurface where bodies can be created and edited for modelling.  In this 
example we are modelling depth below the ground surface (black line) and the altimeter 
channel provides us with a vertical position for the sensor (blue line).  In most airborne 
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surveys you will have access to a sensor elevation channel and a ground surface elevation 
channel and this allows your models to have absolute elevation values. 

 

Note that the first order regional magnetic field is shown as a red sloping line with two square 
fix points positioned at either end of the profile.  The fix points can be selected and by 
holding the left mouse down, dragged to a new position.  When model computation is in 
immediate mode, the regional will be recalculated with each new position.  For more 
information on managing 2D regionals refer to Chapter 6 in the Geophysical Interpreters 
Guide. 

Change the depth of your cross-section to 500 metres as this will provide more sensitivity for 
visual editing of the models.  To access this control, position the cursor inside the section 
below the thick black horizontal line representing the elevation channel and use a right-
mouse click to access the configuration pop-up menu and select the Track 0>Vertical Range 
sub-menu. 

 

 
The Compute button on the Model toolbar is used to compute the forward model 
response curve after a series of edits.  

 
The Manual/Immediate Mode button allows the user to toggle between Manual 
and Immediate compute modes. 

 
When highlighted green the button is in Immediate compute mode. 

Set the computation mode to Immediate for this tutorial. 

Adding Models to a Cross-Section 

Once a cross-section is created it is possible to then introduce individual bodies to form a 
model. The creation of bodies is accomplished from the Create Body button on the Model 
toolbar. This dialog can also be opened from the Model>Body Operations>Create Body 
menu option.  
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Any of the listed body types can be created in a cross-section, but the Tabular body is used 
in this example.    

Step 10 

Highlight the Tabular body shape from the Create Body dialog and click on the colour 
square to change the colour of the body. Also enter a susceptibility value of 0.01 and a strike 
length of 2000m.  

Step 11 

Move the cursor into the cross-section window and directly beneath the large anomaly drag 
out a narrow but deep rectangle and release the mouse button to reveal a body similar to 
that illustrated below. 

 

Double mouse click on the tabular body in the cross-section window to display the Body 
Properties dialog. Edit the Susceptibility, Thickness, Depth Extent, Dip and Z value of the 
body to match that illustrated in the dialog below and click Apply and Close to return to the 
cross-section window. 
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Step 12 

Adjust the regional fix points to set the model regional level. After computing the resulting 
body should like similar to that illustrated below. To move the body along the x-axis, left 
mouse click on the body to activate the edit mode (identified by the black nodes in the corner 
of the body) and then left click (hold) and drag the body to the new position.  

Step 13 

Save this session as a new file called TUTE_NEW.SES by selecting the File>Save As… 
menu option. Save this file to the same folder as the Project file i.e. ..\TUTORIAL\TUTE1. 

 

Stacked Profile Displays 

A stacked profile of data lines can be produced in ModelVision using the 
View>Map>Stacked Profile option.  

For this tutorial exercise, you can continue with the session already saved or clear all 
windows by selecting the Close button in the top right hand corner of each open window. 

Step 14 

After importing the dataset (see above) selecting the View>Map>Stacked Profile option will 
present a dialog allowing the selection of channels contained within the dataset to be 
displayed in a stacked profile display.  
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One or more channels can be selected for display. Highlight the MAG channel in the 
Available list on the left hand side of the dialog and click the Select button to move this 
channel to the Selected list on the right hand side.   

If an existing contour or stacked profile window is open, a check box provides the option for 
the requested stacked profiles to be added to this window. For this example there are no 
other map windows open yet so it will create a new map window for the stacked profile. 

Step 15 

Once the channel(s) is selected, select the OK push button and a map of the dataset lines 
will be displayed in a new map window. 

 

If the initial view of the map is not correctly positioned or scaled use the Zoom In/Out, Pan 
and Fit buttons of the Display Toolbar. By default, the viewing area of the stacked profile 
map and the scaling of the selected channel(s) are automatically computed. 

These attributes can be reset after the stacked profile window is opened. The stacked profile 
map can be configured using the Map Configuration dialog, accessed from the pop-up menu 
option. 
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Configuring Map Displays 

Step 16 

Stacked profiles are an example of a map display. Other map displays include contours, 
images and grid profiles.  

Common to all map displays is a Map Configuration dialog that is used to control the many 
display parameters. Once a map display has been created, other map presentation types 
such as contours, drillholes or backdrops can be added, deleted or configured. Each map 
display has its own configuration dialog, but access to these controls is the same for all map 
types. The stacked profile dialog is shown below. 

Step 17 

Position the cursor over the map window containing the stacked profile and click on the right 
mouse button to display a pop-up menu containing the Configure Layers option. Select this 
menu item and the Map Layers table will appear. Ensure that the Stacked Profile Channels 
object type is selected for the MAG channel; (this channel should be displayed in the table 
beneath the various Object Types) and right mouse click on the Configure option from the 
pop-up menu that appears.  

Step 18 

Adjust the Z-Scale, Baseline Value and Shade Above values as illustrated in the above 
dialog. Click on the Colour button for the Shade Above option and specify a light blue 
colour. Click OK on both dialogs to return to the map window containing the stacked profile 
and observe the changes made. 

Note If you are using the original data used in the previous exercise for displaying a 
cross-section you will observe the modelled tabular body in the map window. This 
can be hidden from view by turning off the Body tick box in the Visible column of 
the Map Layers table. 

 

Note 

 

The Baselines for the survey will be highlighted in pink indicating that these lines 
are still active from the modelling performed in the previous exercise. These can 
be deselected from the Select Lines button in the Model>Line Control menu 
option or else select the Active Lines button from the Modelling Toolbar. 

 

Contour Displays 

A contoured display can be presented using the View>Map>Contours option. For this 
tutorial exercise, you can continue with the session already saved or clear all windows by 
selecting the Close button in the top right hand corner of each open window. 

Contours are drawn from a grid stored in memory. The grids can be either imported or 
generated by ModelVision. Generated grid files can be derived from any loaded channel so 
both theoretical and measured data can be used. The procedure to be used for creating a 
grid within ModelVision is controlled by the Utility>Grid Channel Data menu option. 

Step 19 

To grid the channel data from the line survey imported select the Utility>Grid Channel Data 
menu option to display the below dialog. 
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Select the MAG channel to grid and leave the default name as MAG. Round the Grid Cell 
Size to 100 and leave the Expert Parameters as their default. Click OK to compute the grid.  

Step 20 

Select the View>Map>Contours menu option and the grid selection dialog box will appear.  

 

Step 21 

When the When the MAG grid is selected and OK is pressed a contour map window will 
display as illustrated below. 
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Step 22 

The smoothness and presentation of the contours are a function of the grid that is used. 
Smaller mesh sized grids will produce smoother contours but take a longer time to compute 
and draw.  

To configure the speed of drawing and the contours of a map press the right mouse button 
with the cursor over the contour window select the Configure Layers option from the pop-
up menu that appears and display the Map Layers table. 

View the Contours layer in the table and ensure the MAG grid is highlighted in the Name 
column box. Right mouse click on the Contours layer and choose the Configure option from 
the pop-up menu that appears to display controls for the presentation of contours. Colour, 
contour interval and the level of dropout of the contour display are all controlled by this 
dialog. 

 

The dialog identifies the grid being used to generate the display. The contour interval to be 
used can be specified by the user (Manual Spacing) or automatically selected by 
ModelVision (Auto Spacing). When the manual mode for contour spacing is used a minimum 
and maximum value can be specified that will provide clipping of the contour level beyond 
these limits. Dropout controls the density of the contours drawn by defining the number of 
contours drawn per centimetre of display. 
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The Decimate option affects the speed with that a grid will be contoured. For example, a 
large dataset would take considerable time to contour and may have too high a resolution to 
be displayed in the window in any case. Because of this, ModelVision can be forced to skip 
every nth row or column for display and contour generation. This decimation process 
increases the speed of contouring enormously. Care should be exercised in setting the 
decimate value so that aliasing does not bias the contoured result. 

Step 23 

Save this session as a new file called TUTE_NEW.SES by selecting the File>Save As… 
menu option. Save this file to the same folder as the Project file, i.e. ..\TUTORIAL\TUTE1. 

Grid Profile Displays 

A Grid Profile display can be presented using the View>Map>Grid Profiles option. For this 
tutorial exercise, you can continue with the session already saved or clear all windows by 
selecting the Close button in the top right hand corner of each open window. 

ModelVision can display a grid image of the rows or columns of an imported or generated 
grid by first of all gridding the data. This form of presentation is useful for modelling data from 
a grid since attempting to model by other grid displays (such as contours or imagery) is 
difficult. It is possible to control the number of rows and columns displayed thus making the 
presentation easier to visualize and faster to display. Control is also available to alter vertical 
scaling, display either rows, columns or both and the colour of the profiles. 

Step 24 

After selecting the View>Map>Grid Profiles option, choose one or more grids and whether 
rows, columns or both are to be used. The direction of the rows or columns will always 
match the orientation of the input grid in a vertical or horizontal sense. 

 

Step 25 

Display the Grid Profiles in row form initially. You may wish to extend this to both rows and 
columns to experiment with the display. 

 

Note When first accessed, large grids will automatically be decimated, as presentation 
of every row or column in such cases can fill the display and be confusing in 
appearance. Decimation is the process of not displaying every row and column. 
This process speeds up the display operation, but can be overridden by 
configuring the display. 
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Step 26 

Control of amplitude, decimation factor and colour of the display are accessed from the Map 
Layers table. The table is accessed by pressing the right button while the cursor is 
positioned in the Grid Profile window, and then selecting the Configure Layers option from 
the pop-up menu.  Then click on the right mouse button while the cursor is positioned over 
the Grid Profile layer in the table and select Configure. 

If both row and column decimation are used, then skipping in these two directions is 
implemented. 

The vertical scaling (Z-Scale) and Baseline Value of the display are automatically computed 
using line data, if available, such that a stacked profile display will have the same vertical 
scaling as the grid profiles if they are displayed together. 

 

 

Note The vertical scaling uses units/centimetre as its unit measurement. Computed 
values can be overwritten. 

 
Modelling of grids generally requires compression to be turned on. The Model Compression 
factor should be selected to match the row or column decimation value. For example, if the 
grid profile decimation value is 2, use a Model Compression factor of 2, 4, 8, 16 etc. 

Grid Image Displays 

An image display can be presented using the View>Map>Grid Images menu option. For 
this tutorial exercise, you can continue with the data already imported (TUTE.HDR, 
TUTE.LIN data from the /EXAMPLES folder), or clear all windows by selecting the Close 
button in the top right hand corner of each open window.  

Note If you are running ModelVision in Demonstration Mode, import TUTE1_NEW.SES 
using the File>Open>Session menu option. 

 
Image displays are drawn from a grid stored in memory. The grids can be either imported or 
generated by ModelVision. Generated grid files can be derived from any loaded channel so 
both theoretical and measured data can be used.  
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Step 27 

When the Map>Grid option is selected, the grid selection dialog box appears. 

 

Step 28 

When the grid is selected and OK is pressed the image will display. 

 

This form of presentation is useful to preview and obtain information that highlights anomaly 
highs and lows by their shaded representation. ModelVision cannot enhance imagery with 
the powerful options or functions available in software packages such as ER Mapper but it is 
capable of providing a fast previewing facility. 

Note The appearance of a screen image is determined by the colour depth available 
with the computer hardware used. Displays with only 256 levels of colour will not 
produce high quality images. With colour levels greater than 256, the quality of 
the image will be significantly enhanced. On most computer video hardware, the 
colour depth can be increased but at the expense of reduced screen resolution. 
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Step 29 

The smoothness and presentation of the image are a function of the grid that is used. 
Smaller meshed grids will produce smoother images however these will take a longer time to 
compute and draw. 

To configure the appearance of the image display, press the right mouse button with the 
cursor over the image window to display the Map Layers table. Select the Image layer and 
ensure that the appropriate grid name appears in the list box. Double click on the Image 
layer in the layer table to view the Image Configuration dialog and to control the image 
illumination and colour rendering. 

 

Data values stored in the grid are presented in the image display as a surface that is 
artificially illuminated by a computed light source. You can alter the location and the intensity 
of the light source by the controls contained in the dialog. 

Note Even though a reduced colour depth image may be displayed on screen, 
ModelVision will use the full resolution and colour depth available when output to 
a printer or plotter. 

 
The colour representation of the high and low areas of a displayed grid can also be modified 
by altering the colour look-up table. Three colour modes are available for the image display:  

Mono 

A single colour is used to present the image and shades of grey are then overprinted to 
provide gradient information. This is useful when you are interested in trend information and 
not amplitude. The colour used in this mode is definable by the Set Colour push button. 

High/Low 

A dual colour display where images above and below the average value of the grid are 
displayed in user definable colours. 

Table Lookup 

A number of external image palettes are available for setting and controlling the range of 
colours of the image representation. The order of colours in the colour table can be used to 
influence the perception of amplitude. For example, a table with colours ranging from blue to 
red can be used to great effect to display an image with low to high amplitudes. The palettes 
have a definition identical to that adopted by Leica’s ER Mapper. The image colours are 
uniformly spread across the amplitude range of the grid data. 

Pan and Zoom facilities from the Display Toolbar are available for the image map display. As 
for the other map window displays, contours, backdrop files, stacked profiles, flightlines, 
baselines etc. can be used as part of the image window display. In all cases these will plot 
over an image display. 
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Both observed and theoretical modelling responses can be presented in image form and 
updated as models and bodies are edited. To do this, ensure that the Grid Control option for 
modelling is set on and a grid has been created. Any alterations that are made to edited 
bodies will be reflected in both the body location or shape and the contoured display.  

Note The speed of computation and updating of modelled grid output can be controlled 
by the Model>Data Compression option. 

Perspective Display Window 

The Perspective option will display a three-dimensional representation of a model, drillholes 
and surface location of data lines. The view can be rotated in space in a variety of planes so 
an optimal perspective of the model can be achieved.  For this tutorial, you can directly 
access a perspective display by selecting the File>Open>Session option and selecting the 
file TUTE1A.SES. 

Step 30 

This session contains a 2D map display of stacked profiles displaying a stacked profile data 
object of the MAG channel plus some simple tabular bodies modelled along line 1500.  

Select the View>Perspective menu option. A display window will then present a perspective 
view of the model with each body drawn according to its default display mode.  

 

This is typically similar to the Solid mode where each body will be filled with a different 
colour and be shaded in a style to suggest 'depth' and three-dimensionality. The bodies will 
be enclosed by a surrounding Wire Frame Box that will have its top surface at ground level 
and dimensions that relate to the size of the enclosed bodies. If at any stage the display of 
the perspective does not appear to enclose all the bodies, drillholes or data, select the Fit 
option from the Display Toolbar.  
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Step 31 

Various methods are available to manipulate and move the Perspective view into the optimal 
viewing position. The user viewpoint is referenced to an origin that appears as a three co-
ordinate axis labelled as x, y and z. The horizontal and vertical slider bars in the Perspective 
window will change the user's viewpoint of the display. The horizontal slider bar will rotate 
the view around a vertical axis. The vertical slider bar controls movement of the display 
around a horizontal axis. The viewing azimuth and inclination between the user's viewpoint 
and the model centre is listed in the window. 

Step 32 

 
Use the 3D Navigation button on the toolbar to control the viewing position in a 3D 
display area. After selecting this button navigation in 3D is performed in 3 different 
methods: 

• Clicking on the left mouse button will rotate the 3D area around a central axis position.  

• Clicking on the right mouse button and moving the cursor around the 3D display will 
activate the zoom in/zoom out navigation options.  

• Clicking on both the right and left mouse button together will activate a fly-through 
effect.  

Note To move the position of the central axis point relative to the display area hold the 
SHIFT key down and click on the left mouse button while moving the cursor to 
either the top or bottom of the display area. 

 

Three separate entities can be displayed with the Perspective view. These are: 

• Models and individual bodies. 

• Locations and data of loaded drillholes can be displayed. Colour modulated values or 
vectors can be displayed along the drillhole path. 

• Survey lines are displayed on the surface. Active model lines are displayed in red.  

• Grid surfaces with z scaling and colour modulation options. 
 

Note The survey line is displayed on a zero datum and does not currently use the 
elevation channel. 

 
Removal of hidden surfaces is a computationally intensive operation and ModelVision makes 
some approximations to provide rapid 3D visualization. In some circumstances the body 
ordering is not correctly visualized. If this occurs, try changing the viewpoint with the slider 
bars.  

Control of the displays is provided by positioning the cursor in the Perspective window and 
then pressing the right mouse button to select the Configure Layers option from the pop-up 
menu. If you are in 3D Navigation mode at the time, hold down the CTRL key while clicking 
the right mouse button to display the pop-up menu. 
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Step 33 

A loaded grid can be displayed in 3D by selecting the 3D Grid radio button in the 
Perspective Configuration dialog. The name of the loaded grid should be displayed in the 
drop down box in this dialog. If there is no grid name displayed then you will need to load a 
grid by selecting the Add button.  

With the loaded grid name visible click on the Configure button and the 3D Grid 
Configuration dialog will appear, allowing you to select the Table Lookup Palette of 
Pseudocolor from the drop down box, and adjust the Z-scale of the grid to be 5.0. Also 
increase the transparency of the grid by moving the slide bar to the right for the Continuous 
Transparency option.  

Click OK in both dialogs to return to the Perspective window and observe these changes. 

 

Drillhole Displays 

Downhole data obtained from drillholes can be viewed in a variety of displays, including map 
windows, perspectives and cross-sections. For this part of the tutorial save and close the 
session created so far (File>Save) and clear the memory using the File>Close menu option.  

Step 34 

Using the File>Import>Drillhole Data>Simple XYZ (.LIN) menu option import the file 
DHOLES_EXAMPLE.LIN file located in ..\EXAMPLES\DRILLHOLE. 

Once loaded, use the Utility>Statistics>Drillhole Data menu option to display information 
on the location of the drillholes and their downhole data values.  

Step 35 

Open a new map window by selecting the View>Map>Empty Map menu option. Click the 
right mouse button while the cursor is positioned in the map window and select Configure 
Layers to view the Map Layers table. Click the right mouse button anywhere in the table and 
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select the Add>Drillhole option to select the two available drillholes (DDH1800 & 
DDH1920). Click OK to return to the map window and Map Layers table.  

 

Step 36 

Control of the drillhole display is made available by selecting the Configure option in the 
pop-up menu when the Drillhole layer is selected with the right mouse button. This will 
display the Drillhole Configuration dialog as illustrated below: 

 

Note The same configuration options for drillholes are available in the X-section and 
Perspective configuration dialogs. 

 
This drillhole configuration controls the display, colour, scaling and channels to be used for 
vector displays. Display controls available include: 

Track 

This option controls whether a trace of the drillhole is shown. A drillhole trace is presented as 
a line that joins the hole locations as defined by the X, Y and depth channels in the loaded 
data. 

Symbol at each point 

Displays a '+' symbol at each hole measurement location. 
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Vectors 

Vectors are referred to in ModelVision by three components parallel to the X, Y and Z axes 
with default names of VX, VY and VZ. Scaling of the length of the vector is controlled by the 
Auto Scale option. Selection of the vector components is defined in the Vector Component 
Selection option. The individual vectors can be represented as lines or arrows radiating out 
from the drillhole trace. 

Colour Mode 

Three modes of representing the vector displays of drillhole data are available. These are: 

• Single definable colour (Mono or colour) 

• High/low dual colours 

• Table lookup colour ranges 

The colours used to display the vector amplitudes can also be modulated by a nominated 
channel. For example, if the three component vectors of downhole magnetics are VX, VY 
and VZ but the display is coloured according to the total magnetic vector, then the Compute 
operation could be used to calculate a new channel that represents the total vector 
amplitude √(VX2 + VY2 + VZ2). The new channel could then be used to control the colour of 
the vector display. 

A colour legend can be displayed to indicate the vector colours used. 

Step 37 

For this example select the Wire Track Display type and allow for auto scaling by selecting 
the Auto Scale check box. For the Colour Mode select the Table Lookup radio button option 
and specify the Pseudocolour palette for colour modulating the drillholes by the MAG 
channel. 

This concludes the introductory tutorial for ModelVision. If you would like to continue your 
education with using the software please refer to the additional tutorials in the 
Documentation folder. 
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Tutorial 2 – Display, Filtering and Controls 

Aim 

The aim of this tutorial is to demonstrate how data can be presented in various forms and to 
illustrate the ease with which various relationships between multi-channel information can be 
derived. An introduction to filtering and the calculator option are also provided. 

Topics Covered 

• Data Import 

• Multi-Track display and control 

• Convolution Filtering 

• Calculator option 

Intended User Level 

Basic introductory and a refresher for experienced users. 

Background Information 

Contained in the data file for this tutorial is a single airborne profile extracted from a much 
larger survey flown in 1992 in northern New South Wales (Australia). This survey data has 
been designed with traverses that are oriented north to south. Within the data file are AMG 
coordinates, Fiducials, Magnetics and spectrometer channels of Potassium (K), Uranium (U) 
and Thorium (Th). The survey was over a granitic margin with the intention of determining 
the shape of the granite edges. Poor mapping in rough terrain and extensive overburden 
masked much of the granite boundaries. The target being sought in the area are tin skarns 
that are known to exist locally. 

Tutorial Data 

For this tutorial you will need to Import a file called TUTE2.TK. This single line of data has 
been extracted from a north-south oriented airborne survey and is a sequential line file 
containing 1999 data records. The data file is written in TOOLKIT multi-column ASCII format 
and is required to be read using the Import TK Option. See Tutorial 1 that describes the 
steps taken to import a dataset if you have difficulty in initially reading the data file. 
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Tutorial Steps 

The following tasks should be undertaken to familiarize yourself with an analysis of typical 
airborne data in ModelVision: 

Step 1 

Initially, a project is required to define the various properties of the data. ModelVision uses 
projects to manage various analysis exercises and a MVPROJ.INI records your entries for 
later use. Binary session files (.SES) can also be used to store data, models and displays if 
required. 

Select the File>New Project option and enter the information as required. For this area and 
projection information includes: 

 Datum:  Australian Geodetic Datum 1966 (AGD66) 
 Projection: Transverse Mercator 
 Zone:  AMG Zone 55 (TMAMG55) 

 

You can use the IGRF button to accurately position the survey (147o 6.33’E, 51o 31.75’S) 
and compute the Earth’s magnetic field parameters. Defining the Earth’s magnetic field at 
this stage ensures that any magnetic modelling performed later in the ModelVision session is 
correctly calculated. 

Modify the Project Details as required. When the necessary entries are made, press the OK 
button. 

Step 2  

Using the File>Import>Profiles>Toolkit Format (.TK) option import the data file called 
TUTE2.TK located in ..\TUTORIAL\TUTE2. 

Then examine the data using the Utility>Statistics>Line Data menu option to determine 
line extent, channels ranges etc. 
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Note The distance (DIST_ABS) column has been computed automatically from the 
northing and easting data as distance calculated from the first data point location 
of a line to the relevant record location of each successive point. The results in 
the DIST_ABS channel are therefore a true distance from the line start and not a 
series of cumulative reading distances. This channel can be used as the 
horizontal scale for plotting and display purposes. 

 
Step 3 

Display the magnetics and radiometrics using the View>Multi-Track menu option to check 
the integrity of the data. The dialog provides a list of the channels to select. Choose the 
magnetics (MAG) and spectrometry (K, U and TH) channels. The Add reference track is not 
ticked by default. For this exercise, select this check box and then choose the OK button. 

The Reference track will display the first 
channel of the selection dialog in the Multi-Track display as a ‘greyed’ track at the base of 
the window. When released, all but the Reference Track will have zoomed to the selected 
portion of data. The scroll bar at the base of the window can then be used to progressively 
move across the data display. When the channels are selected the profile will be displayed.   

Note An option available in the Multi-Track dialog enabled the top portion of the window to 
display a spreadsheet of all the channel values displayed. By double clicking on any 
cell value in the spreadsheet it is possible to edit the values. Additionally, you can 
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select a row number (left column) and the cursor will move to that location in the graph 
if it is in range of the current zoom. The converse is not true.  That is a cursor selection 
in the graph does not move to the matching record in the table. 

 
Step 4 

Return the track to its full size by positioning the cursor over one of the tracks and clicking 
the right mouse button to display the pop-up menu options. Select the Fit Track>Horizontal 
option to adjust the appearance of the track. 

 

Step 5 

It is possible to analyse data and to add tracks to the multi-track display. For example if you 
wanted to examine the relationship between two data channels (such as a spectrometry 
ratio) this can be done and then displayed in the same window as the other selected 
channels. 

Calculate the K/Th ratio (use the Utility>Calculator menu option) and simply enter the 
desired formula as illustrated below. Ensure that the Line mode is selected and to add the 
Channel names to the equation highlight the channel in the list and click on the Select 

button.  

To create a new data channel of the ratio, press Compute after designing the formula. 

Note In the example shown, a new channel (KTHRATIO) will be created when the 
Compute button is pressed. Additional new channels can be created as required. 
This channel will be added to the memory for the loaded data and can be viewed 
in the Line Data Statistics (Utility>Statistics>Line Data menu option). 

 

Note Certain restrictions apply to the use of the Calculator. For example, channel 
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names cannot start with a number and there are reserved words such as SIN, 
TAN, TANH etc. 

 
Step 6 

To examine the shape of the new resultant channel, it can be added to the display in the 
Multi-Track. Bring the cursor to any track and right click. A pop-up menu as shown will be 
presented. Select and press the Add Curve button.  

A new dialog will enable you to select the new channel. 

   

Select the kthratio track and press OK. The new channel is then added to the track initially 
selected. 

Note In the example shown above, for multi-line datasets, the Change Line option is 
very useful to interactively examine a range of lines as required. 

 
Step 7 

If you wish you can reposition any of the data tracks by placing the cursor in the left hand 
header box, pressing the left mouse button and ‘dragging-and-dropping’ the channel to a 
new location. 

Controlling the display attributes of any of the displays of the various channels is achieved by 
double left clicking in the channel header box at the left end of the Multi-Track display. 
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Step 8 

Filtering is a powerful geophysical tool for extracting information from data. ModelVision 
provides two main filter techniques - Convolution and Fast Fourier Transform (FFT) filters. 
Filtering potential field data in particular is useful for: 

• Extracting frequency information specifically from a particular set of depth sources. 

• As a means of extracting noise from data. 

• As a technique for highlighting special features or repairing problem data. 

In ModelVision, filtering is usually first applied on an individual line basis to design a filter, 
and then the option is available to apply the same filter over a range of lines or all data in 
memory. 

Use a series of high pass convolution filters to isolate the near surface response contained in 
the magnetic data. The filter options are accessed from the Filter menu. 

Tip: The spacing for this data is about 10-11 metres collected at an altitude of about 
80 metres above ground so use a range of filters of about 75,100 and 250 metres 
with filter operator of about 15, 21 and 51 respectively. 

 

Note The best method of determining the optimal number of samples in an operator is 
to approximately calculate twice the longest wavelength that you are trying to 
remove from the data. For example, in the above design of a 100 metre 
wavelength high pass filter on 10 metre sampled data, the optimal operator width 
would be: 

   2 x 100 / 10 + 1 = 20 or 21 samples 

 

 

Successively create the three filter outputs. 

Warning: Each time a new filter is created, you must rename the output channel name to 
something appropriate. If this is not done, the filter output will overwrite your 
previously created results. This is done intentionally since in some instances, it is 
a feature to have the Multi-track display update automatically as a revised filter 
design is calculated. 

 



 ModelVision Tutorials 38 

Step 9 

Display the filtered output of each filter using the Multi-Track view option. Make sure that the 
Add Table check box is turned off for this new Multi-Track window..    

Try printing the generated display to a file. To do this, use the File>Print Setup menu item 
and then output the file using the Files>Print option. Note the scale and height controls that 
are available in the Print dialog. 
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Tutorial 3 – Data Analysis and Introductory Modelling 

Aim 

The aim of this tutorial is to extract magnetic noise from surficial sources and then determine 
a model that may be adopted as a drill target for further exploration. The exercise is 
designed to introduce complex filtering techniques and use the reduced data to develop 
basic magnetic models. 

Topics Covered 

• Data Import 

• Multi-Track display and control 

• Convolution Filtering 

• Cross-section creation 

• Introductory modelling using simple models. 

• Introduction to inversion. 

Intended User Level 

Introductory and experienced refresher tutorial. 

Background Information 

The data contained in the file used for this tutorial is a ground magnetic traverse in an area 
near Bourke NSW (Australia). The line crosses an area that contains severe magnetic noise 
produced by maghemite concentrated in paleo drainage channels. High copper and lead 
geochemistry from samples collected in the area of 1550-2050E make it necessary to 
interpret this noisy data. 

Tutorial Data 

Initially, a project is required to define the various properties of the data. ModelVision Pro 
uses projects to manage various analysis exercises and a MVPROJ.INI records your entries 
for later use. Binary session files (.SES) can also be used to store data, models and displays 
if required. 

Select the File>New Project option and enter the information as required. For this area and 
projection information includes: 

 Datum:  Australian Geodetic Datum 1966 (AGD66) 
 Projection: Transverse Mercator 
 Zone:  AMG Zone 54 (TMAMG54) 
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Note that the entries for the Earth’s magnetic field are set to be: 

Field Intensity:  57400 
Inclination:  -44 degrees 
Declination:  10.3 degrees East  

Note The format of the file is a Geosoft single line DAT file. Use a text editor or 
alternatively use the DOS Type command to display the data. The data will 
appear similar to below: 

 
Geosoft Single Line File - Demonstration for ModelVision Pro 
Line:1110 
X Y MAG 
6323282.000 2190063.250 57242.500 
6323284.500 2190072.750 57243.801 
6323287.500 2190082.500 57242.602 
6323290.500 2190092.000 57241.102 
6323293.000 2190101.750 57239.500 
6323296.000 2190111.250 57238.500 
6323299.000 2190120.750 57236.801 
6323301.500 2190130.500 57235.602 
6323304.500 2190140.000 57234.199 
6323307.500 2190149.500 57235.500 
6323310.000 2190159.250 57234.500 
6323313.000 2190168.750 57233.801 
6323316.000 2190178.250 57234.602 
6323318.500 2190188.000 57234.102 
6323321.500 2190197.500 57237.500 
6323324.500 2190207.000 57236.500 
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Tutorial Steps 

The following tasks should be undertaken: 

Step 1 

Use the File>Import>Profile>Geosoft Single Line (.DAT) option to open the data file called 
TUTE3.DAT located in ..\MODELVISION_TUTORIALS\TUTORIAL3. 

or if in Demonstration mode, File>Open Session and browse for TUTE3.SES. 

If you have difficulty reading the data file initially, see Tutorial 1 that describes the steps 
taken to import a dataset.  

The data is a single line of magnetic readings that has been extracted from a ground 
magnetometer survey in the Bourke area of NSW. Only easting, northing and magnetometer 
data channels are present. The magnetometer data has been diurnally corrected.  

 

Step 2 

Use the View>Multi-Track menu option to display the magnetics against the distance 
(DIST_ABS) channel and pay special attention to the wavelengths of the surficial noise 
evident in the data. 
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Note In the profile selection that the Reference Track or data table have not been 
selected for display. 

 

 

Step 3 

Design some long wavelength filters to obtain a variety of outputs that can be used for 
further analysis. The simplest method of doing this is by using the Low Pass convolution filter 
option. Try wavelength cut-offs of 50, 100, 250 and 500 metres. You will note that the data 
has been acquired with a 5 metre station interval. Therefore for this data, filter operators 
would optimally be 21, 41, 101 and 201 samples respectively. 

Note Take care to assign unique names for each filter result. 

 

Note The best method of determining the optimal number of samples in an operator is 
to approximately calculate twice the longest wavelength that you are trying to 
remove from the data. For example, in the above design of a 100 metre 
wavelength low pass filter on 5 metre sampled data, the optimal operator width 
would be: 

     2 x 100 / 5 +1 = 41 samples 

Filter lengths are always an odd number of samples. 

 
Step 4 

Display the generated filter channels using Multi-Track display mode. A Multi-Track display 
of the various filter designs should enable selection of the best filter. 
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Note You will need to define the number of tracks required and not use the Automatic 
option to create the tracks. 

 

 

Adjust the vertical scalings for each track so that all vertical scales are the same (Max: 
57550; Min: 57000). This is done by double clicking the left mouse button while the cursor is 
in the appropriate Track Label (at left end of Multi-Track). Each line needs to be adjusted 
individually. 

 

Step 5 

You may wish to also design a series of high pass filters to isolate the near surface 
response. Once defined, this 'noise' can then be subtracted from the original data to result in 
a long wavelength response as determined above. It is recommended that frequency domain 
filters be tried for the extraction of the high frequency response. This will familiarize you with 
both filtering approaches and enable a comparison of results to be made. 

Step 6 

An alternative filter that may be of use is the spike rejection Median Filter. This filter requires 
a spike rejection threshold amplitude and operator window length to define the wavelength 
sensitivity. The filter incrementally moves along the selected line(s) and compares the middle 
sample amplitude of the window with the difference between the median value of the window 
and the threshold. If the absolute value is greater than the threshold, the median is 
substituted for the value. 

For your test line, test a range of threshold values and compare the results. An example of 
filter parameters set in the Moving Median Filter dialog is shown below. 
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Create a number of Median Filter results (naming the Output Channels uniquely and display 
in a new Multi-Track display. Again ensure all tracks have the same vertical scaling to 
compare results accurately.  

Another filter type that you may consider is an Upward Continuation. We will investigate this 
as an aid to modelling in a later stage of the Tutorial. 

 

Step 7 

Once a bedrock response with minimal surface magnetic noise has been generated, then a 
model can be developed to simulate a target for drilling. Initially it is important to check the 
magnetic field specification for the survey region: 

Earths Total Field  57400 nT 
Declination  -44 degrees (southern hemisphere) 
Inclination  10.3 degrees East 

These parameters are available from the Model>Magnetic Field or the File>Project 
Properties option. 
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Step 8 

To model the filtered response, select the appropriate channel (MAG) as input in the 
Model>Line Control menu option dialog. Click OK to close this dialog.  

Although any of the filter outputs could be used as the input for modelling, it would be difficult 
to estimate the effect a long wavelength filter would have on a derived depth for bodies we 
create in our model. Consequently, during the modelling process, an Upward Continuation 
filter (where the depth effect is known) will be adopted. 
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Step 9 

Modelling will be performed using the View>X-Section menu option. This display will 
present the selected data channel, a computation output channel and a section below the 
data tracks for creating models. 

 

Step 10 

 
Create a Tabular shaped body using the Create Body option on the toolbar or the 
Model>Body Operations>Create Body menu option.  

  

After selecting the body type from the Create Body dialog, position the cursor in the X-
section area and click the left mouse button or click and drag out an enclosing rectangle. For 
this exercise select the simplest body type - a Tabular body. To generate a theoretical 
response after the body is positioned, select the Compute button on the toolbar 

Use the Reshape button or icon once the body(s) has been created to position and orient it. 

You will need more than one body to simulate the response. With the degree of noise 
present in this data it is impractical to model in its current form. 

Step 11 

In-line filters can enhance the precision of forward modelling and enable modelling even in 
these difficult circumstances. In-line filters can be used to provide greater sensitivity between 
the observed and calculated magnetic responses while modelling. Since this test line was 
initially prone to surface magnetic noise, it is important that we know what effect the filter is 
having; we can use an Upward Continuation In-Line filter. To display a track of the in-line 
filter curve you can add it to a X-Section display. Click the right mouse button to select 
Configure Layers from the pop-up menu and display the Cross-section Layers table. 
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Then click the right mouse button on any layer in the layer table and select Add>Standard 
Filters from the pop-up menu that appears. 

 

Note The In-Line filter operates on the original MAG channel and not the derived 
Median or Long Wavelength filters. If desired you may wish to use the Median 
spiked filter data. This could be easily done using the Utility>Calculator option 
and copying the Median filter output to the MAG channel. As a precautionary step, 
you may also wish to rename the original MAG channel to another name. 

 
Select an optimal operator length and continuation height (say 100 metres). When OK is 
selected two new curves will be added to a new track above the X-Section display. These 
two curves will be the Upward Continuation of the computed and observed trace data. 

 

Step 12 

 

 

Use the Create Body toolbar button to create four Tabular bodies similar to that 
displayed above with similar body properties as outlined in the Body Table  
(Model>Body Operations>Body Table menu) dialog. To edit the individual 
body properties double left mouse click on each body in turn to display the body 
property dialog or in the Body Table itself.  
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Note You may need to Fit and adjust the vertical size of the tracks of the display to 
balance the presentation. To fit a track either horizontally or vertically click the 
right mouse button in either track displayed in the x-section and select the Fit 
Track>Horizontal or Vertical pop-up menu options. 

 

 

To apply a label to each body double click the right mouse button on the x-section view and 
select Configure Layers from the pop-up menu that appears. Then right mouse click on any 
row in the Cross-section Layers table that appears and select Add>Body labels. To edit the 
label position the cursor over the label and double click on the left mouse button. This will 
display the Edit Body Annotation dialog. Deselect the Draw Border and Join to Object 
options and adjust the Number of Lines to 2. This will remove the display of the density 
property value. 

 

Step 13 

When a reasonable forward model is finalized, attempt to refine it with inversion. Use only a 
single free parameter initially and apply this to only one body at a time.  

To begin the inversion process display the Inversion dialog by selecting the Inversion option 
from the Model menu.  
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Use the Free selection to display the Inversion – Free Paramaters toolbar which controls 
which parameters to invert on. 

Note Use the ability of selecting a body (by placing the cursor over a body, and left 
mouse clicking) to nominate it for inverting. The name of this body will appear at 
the top of the Inversion Free Parameters dialog. You can then cycle through the 
various bodies without having inversion operate on all bodies at once. 

 

 

Note Only permit parameters that are pertinent to a single line of data to be free in this 
case. Since only a single line of data is available, it is inappropriate to allow the 
inversion to model parameters such as the Y body location, or the Azimuth. These 
parameters require additional line data on either side of the bodies to permit their 
estimation. 

 

 

As the fit and model parameters are improved, free additional parameters and then move to 
select additional bodies to improve their fit. At the end of the modelling exercise, would you 
be confident to drill this target? Where would you drill? Create a cross-section with 1:1 
aspect print ratio to scale the depth and horizontal position for the target body.  
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Access the Track Z Range configuration dialog by clicking the right mouse button on the 
+Curves layer in the Cross Section Layers table and selecting Configure from the pop-up 
menu. Use the X-Section Aspect Ratio set to 1:1 to ensure a vertical to horizontal 
presentation aspect ratio that permits scaling directly from a section print. 

Step 14 

Try printing the generated display to a file. To do this, use the Print Setup option and then 
output the file using the Print option. 

Note Scale and height controls are available in the Print dialog. 
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Tutorial 4 – Multi-line Displays 

Aim 

The aim of this tutorial is to introduce the concepts of multi-line displays, grids and modelling. 
Regional and residual data are also used to examine modelling procedures. 

The modelling exercise is designed to: 

• Examine and assess the data initially 

• Estimate the regional field within the survey area. 

• Produce simple models to simulate the observed magnetic and gravity responses. 
When a satisfactory forward model has been developed, examine inversion to refine 
the results 

• Propose a drill site for testing the developed model of the magnetic and gravity source 
which is coincident with the geochemically anomalous body in the south-west corner 
of the survey. 

• Prepare a Layout window presentation of your interpretation. 

Intended User Level 

Medium and experienced refresher tutorial. 

Background Information 

Geologically, the area contains two discreet anomalies adjacent to a NNW-SSE trending 
dyke. An anomalous body in the south has high copper-gold geochemistry draining south 
and a drill target on this feature is required. The area surrounding the individual bodies 
contains metasediments with low magnetic and gravity response. A regional trend is noted to 
pass through the area. Note that certain cultural features have forced the survey lines to 
deviate from being straight traverses. This can be determined by examining the data point 
locations (or flightlines). It should be recognized that analysis of data profiles such as these, 
is usually augmented by geological knowledge, to some degree. All knowledge of a prospect 
should be considered when developing models and assessing survey data.  

The data file is an ASCII sequential line file containing four semi-parallel data lines with 63 
points on each line. Contained in the file are AMG coordinates, diurnally corrected magnetics 
and Bouguer gravity values. The Bouguer density used in the reduction of these values was 
2.67 g/cm3. 

Tutorial Data 

The contents of file 4LINES.XYZ are to be used for this tutorial. The data has been 
extracted from a ground survey where both magnetic and gravity data has been acquired 
over a group of four parallel traverse lines. Note that if you are using this Tutorial while 
operating ModelVision in Demonstration mode, load the data from TUTE4.SES (using the 
File>Open>Project option). 

Tutorial Steps 

The following tasks should be undertaken with this data: 

Step 1 

Open the project file in the \MODELVISION_TUTORIALS\TUT4 folder and then select the 
File>Import>Profiles>Geosoft Multi Line (XYZ) menu option to load the data file called 
4LINES.XYZ. Note that the file extension is XYZ (this indicates the data type is Geosoft 
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multi-line. Use a text editor or alternatively use the DOS Type command to examine the file 
prior to importing this. A portion of the data for the file appears as below: 

Line 1600    
\ (EAST) (NORTH) (MAG) (GRAV) 
200 53800 56481 -0.01 
220 53810 56479.5 0 
240 53820 56478.4 -0.003 
260 53830 56477.5 -0.001 
280 53840 56477 0 
300 53850 56476.8 0 
320 53860 56476.7 -0.001 
340 53870 56476.7 -0.003 
360 53880 56476.7 -0.005 
380 53890 56476.7 -0.008 
400 53900 56476.4 -0.011 
420 53909.2 56476 -0.014 
440 53917.6 56475.4 -0.017 
460 53926.4 56474.5 -0.02 
480 53936.8 56473.3 -0.022 
500 53950 56471.9 -0.023 
520 53968.2 56470 -0.023 
540 53989.6 56467.8 -0.022 
560 54010 56465.5 -0.021 
580 54030 56463.3 -0.019 
600 54050 56461.3 -0.016 

 
Step 2 

Once the data has been imported examine the extent and range of the data using the 
Utility>Statistics>Line Data menu option. Note that the Z-Channels are labelled as CH1 
and CH2 (Magnetics and Gravity). This is because the Geosoft multi-line format does not 
label the channels in the file in other than in a comments line (indicated by the backslash in 
the first column). 

 

As it is more convenient to have channels with appropriate channel names, use the 
Utility>Data Maintenance>Line menu option to rename the channels as MAG and GRAV. 
Click on the Channel Maintenance button in the Line Data Maintenance dialog to view the 
channel names. Then highlight the channel to be renamed and select the Rename button to 
enter the new name.   
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Step 3 

Display the MAG and GRAV data channels as Stacked Profiles using the 
View>Map>Stacked Profile menu option.  

To adjust the vertical scaling of these channels make the map display window active and 
click the Layer Table button in the main toolbar to view the Map Layers table. Then click 
with the right mouse button the Stacked Profile Channels layer in the table and click on the 
Configure option from the drop down list beneath the object types. The Scaling can then be 
adjusted from the pop-up menu that appears. A vertical scaling of 200 units/cm for the MAG 
and 0.2 units/cm for the GRAV will highlight the magnetic and gravity profiles on the display 
as shown below.  

 

Note The position of the anomalies and also note the position of the traverses and their 
orientation (turn on the FlightLine layer in the Map Layers table to reveal the track 
of the traverses). 

 
Step 4 

The data can also be presented as either (or both) contours or an image. To do this a grid 
must be initially created using the Grid Channel Data option in the Utility menu. Nominate 
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an appropriate grid cell size and create a magnetics and gravity grid. For additional 
information on gridding, review the Display Tutorial (Tutorial 5).  

 

Display the grid as a contour map by selecting the View>Map>Contour menu option. 
Display the Map Layers table (right click on the map and select the Configure Layers pop-
up menu option) and with the Contours object type selected with the right mouse button click 
on the Configure option in the pop-up menu that appears to display the Configure Contour 
dialog. Apply a Table Lookup Colour Mode with Palette of Solid Contour and click on the 
Add Legend button to display a legend for these colours based on the MAG data values.   

 

A display of the contours indicates a strong anomaly in the centre of the area, trending north-
westerly. Other associated anomalies in the northeast and southwest are also noted.Display 
the same grid as an image (View>Map>Grid Images) and vary the display attributes by 
altering the decimation, sun angle, colour and data range.  
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Imaging the grid is a fast method of assessing the data and developing an initial starting 
point for on-going interpretation. 

Note On some computers with video display characteristics which are only capable of 
presenting 256 colours, the imagery may not be ideal. This is due to the fact that 
of a 256 colour capability, only 16 true colours (at pixel resolution) are capable of 
being displayed – the other 250 colours are dithered which is not useable by 
image presentation. The only method of improving this is to increase the number 
of available colours in the hardware. 

 
Step 5 

From either the contour or image displays, it is apparent that a regional effect is present in 
the data. To assess the regional effect, a regional surface can be generated and then, if 
necessary, extracted from the line or grid data to improve the data for modelling. 

Select the Model>Edit Regional>Magnetics option to create a magnetic regional surface. It 
is possible to create a regional surface over only selected lines (see the Active Lines 
button). In general practise, you would assign only those lines which are representative of 
the background regional effects and not influenced by local anomalism when choosing the 
Active Regional lines. 
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Note You must define a polynomial order to apply to the selected data when creating a 
regional surface. Generally you will need to use the lowest order polynomial which 
suits the ‘geological’ regional. After defining the lines to operate on, and the 
polynomial order, select the Compute from Data button to create a regional. 
Note that the polynomial parameters computed are displayed and these define 
the surface created. If you wish the surface to be also represented as a grid, 
select the Generate Regional Grid button. 

 

 

Note To this point the tutorial steps have concentrated on analysing the magnetic data 
and only minimal processing has been undertaken on the gravity data.  Similar 
display and regional analysis steps to the gravity data could be undertaken.  
Duplicate menu items are provided in the various ModelVision menu options and 
dialogs to manipulate the gravity data. 

 
Display the regional grid as a contour or image. You will be able to tell from the display 
whether the regional grid is representative of the regional effect. 
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Step 6 

In preparation for modelling, use the Line Control option in the Model menu to control the 
channels to be modelled (MAG and GRAV and regional channel - MAG_REGIONAL). 
Enable all of the lines available to be modelled (Select Lines button) and turn on modelling 
for both Magnetics and Gravity.  

 
Making lines active for modelling can be done either from the Select Lines list of 
the Model>Line Control option, or by using the Active Line toolbar button and 
dragging the cursor (now appearing as a cross-hair) over the lines to be made 
active.  
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Step 7 

Use the View > X-Section option to display the observed data with the regional enabled and 
the computed response (which initially will overly the regional curve) for Line 1700. 

 

Step 8 

In all magnetic modelling, it is important to use the correct value of the Earth’s magnetic field 
within the area being analyzed. In the area studied here, the following field parameters 
should be used: 

Earth’s Total Field: 56500 nT 
Inclination:  -56 degrees 
Declination:  5.4 degrees 

The setting of these parameters is undertaken from the Model>Magnetic Field menu option 
or else in the Project Properties dialog (File>Project Properties). 

Step 9 

   
Enable the Immediate Computer (green) mode button and create some Tabular 
bodies which will simulate a measured response. Refer to Tutorial 3 for 
additional information on creating bodies. In the example provided here, the 
modelling has been undertaken on Line 1700N since in the south-western 
portion of this line an anomaly exists.   

 
Step 10 

Investigate the use of Single Body Responses, and In-Line Filters. The Single Body 
Response option displays the theoretical responses of an individual body.  

   
Firstly, access the Cross Section Layers table by clicking on the Layer Table 
button in the main menu and click on any layer in the table with the right mouse 
button to select Window>Single Body Response track. 

In the X-Section window position the cursor over the first body. Double click the left mouse 
button and display the Body Properties dialog. Select the Display button for the Single 
Body Response group item and when OK is clicked to close the dialog the cross-section re-
displays with an additional track containing only that body’s theoretical response.  



 ModelVision Tutorials 59 

 

Repeat this for the other two bodies being modelled and the cross-section display should 
look like the image below: 

 

Step 11 

To refine and complete the modelling, implement inversion and carefully select parameters 
to be free starting with only the Property and Z value (depth to the top of the body). Modify 
these parameters and develop a feeling for the sensitivities of varying the values. Use 
tolerances if required to limit the range of inversion solutions.  

Refer to Tutorial 3 for an introduction to inversion. 

Step 12 

Progress through the lines sequentially until optimal fits for each traverse are obtained.  
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Another technique worth investigating is to create a grid of the residual and set the Grid 
Control option (in the Model menu) to enable re-computation of grids after editing of the 
model is performed. This technique requires that the residual contours are minimized so the 
differences between the computed and observed responses approach zero. If the time to 
compute after each body edit becomes too long, try using the Data Compression option in 
the Model menu. 

Step 13 

When satisfied with the obtained model, estimate a drill site for the south-western anomaly. 
Note that an optimal location is approximately 670E on line 1700 N, angled to the SW at 
approximately 60 degrees. 

You can use the X-Section Aspect Ratio setting of 1 to provide a section which has the same 
vertical to horizontal scaling. 

Step 14 

Generate a Layout window (View>New Layout) in which a map and section plus 
explanatory notes can be laid out for a presentation.  

To change the order of the data objects in the map window use the Drawing Order dialog 
accessed from the Map Layers table by selecting the Drawing Order option from the 
Windows pop-up menu option, visible when any of the layers in the table are selected with 
the right mouse button. For example, to display the Stacked Profiles on top of the modelled 
bodies highlight the Stacked Profiles object in the list of the Drawing Order dialog and click 
the Up or Down buttons reposition the object in the drawing order. 

 

If a printer is available produce a printout of the finished product. 
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Note ModelVision is not compatible with some print drivers. If a warning message 
appears informing you that the printer set in File>Page Setup or Print menu 
option is not compatible you are given the option to print to a free to download 
and use PDF writer software program called, PDF995. 
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Tutorial 5 – Gridding, Lines, Points and Displays 

Aim 

The aim of this tutorial is to introduce grid manipulation and data extraction techniques. Point 
data which is randomly acquired is frequently available in regional areas. Such data can be 
effectively used to assist higher resolution data interpretation. This exercise illustrates some 
of the ‘lateral’ ways in which ModelVision can be used. 

Intended User Level 

Introductory, medium and experienced users. 

Topics Covered 

• Data Import

• Grid generation and grid import

• Calculator point interpolation

• Graphical point editing.

Tutorial Data 

The contents of TUTE5 files are used for this tutorial. The files include: 

TUTE5.XYZ Airborne magnetics data 
TUTE5 ER Mapper grid of airborne data 
TUTE5.ERS ER Mapper grid header 
TUTE5.PTS Ground data points of gravity 
TUTE5_GR ER Mapper grid of gravity data 
TUTE5_GR.ERS ER Mapper gravity grid header 

This exercise uses two grids (magnetic and gravity), in addition to magnetic line data to 
illustrate how co-sampled gravity data can be derived. It is rare that gravity data is available 
at the same sampling density as magnetics. More coarsely sampled gravity data may, 
however, be available from a local and regional gravity survey. This exercise illustrates a 
method whereby one dataset can be used to extract data from another. 

The survey area involves a semi-regional gravity dataset plus a detailed airborne magnetics 
survey. 
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Tutorial Steps 

The following tasks should be undertaken with this data: 

Step 1 

The basic dataset used in this tutorial is TUTE5.XYZ. Note that if you are in Demonstration 
mode, the TUTE5.SES file can be used instead of importing the necessary data and grid 
files. Loading the session file will also create the necessary project information. 

If you wish to import the ASCII dataset (TUTE5.XYZ) you will initially need create a project or 
at least load the already existing project. To create a new Project file, select the 
File>New>Project menu option and after selecting the Browse button to navigate to the 
TUTE5 folder enter the following information: 

 

For importing the TUTE5.XYZ dataset, the file is a multi-line Geosoft dataset of airborne 
magnetics with easting, northing and magnetic data. Load the TUTE5.XYZ aeromagnetics 
line data file using the File>Import>Profiles>Geosoft Multi-Line (XYZ) option. The data 
being imported appears as below if viewed in a text editor program (e.g. Notepad): 

Line 1000 
288399.375 6554725.5 58058.242 
288841.438 6554725.5 58017.32 
289283.5 6554725.5 57880.383 
289725.563 6554725.5 57724.328 
290167.625 6554725.5 57774.047 
290609.688 6554725.5 57864.094 
291051.75 6554725.5 57984.188 
291493.813 6554725.5 57935.434 
291935.875 6554725.5 57921.984 
292377.938 6554725.5 57915.672 
292820 6554725.5 57879.086 
293262.063 6554725.5 57981.961 
293704.125 6554725.5 57989.727 
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294146.188 6554725.5 58015.801 
294588.25 6554725.5 57976.426 
295030.313 6554725.5 57959.805 
295472.375 6554725.5 58004.629 
295914.438 6554725.5 58025.348 
296356.5 6554725.5 58023.938 
296798.563 6554725.5 58120.633 

 
Use the Utility>Data Maintenance>Line facility to rename the magnetics channel 
(Z_CHAN) to MAG or another meaningful channel name. This requirement exists because 
the Geosoft file has no channel name header information.  

Display the data in a map view as Stacked Profiles using the View>Map menu option.  

 

Note In the statistics for this tutorial, the magnetics have been de-sampled by 
interpolation to reduce the original data volume. 

 
Step 2 

Grids can be generated in ModelVision, or imported from other sources. In this case, a grid 
of aeromagnetics data is contained in the ..\TUTORIAL\TUTE5 folder with header file 
TUTE5.ERS (an ER Mapper file format).  

Import the grid using the File>Import>Grid>ER Mapper option. Take note of the message 
that appears regarding the name of this grid. The message appears because nothing 
meaningful has been included in the description of the ER Mapper header (which is often the 
case).  

 

You will need to rename the grid for use in the calculator function using the Utility>Data 
Maintenance>Grid menu option. Display the grid as contours or as an image over the 
stacked profiles (using the View>Map>Contour or in the Map Layers table for the map 
window click the right mouse layer on any layer and choose the Add>Grid Contour or 
Add>Grid Image button to load the newly named MAG grid). 
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Step 3 

Load the gravity data points from the file TUTE5.PTS using the File>Import>Point 
Data>Simple XYZ (.PTS) – standard menu option. Use an editor such as Notepad or 
Wordpad to examine this file before importing. 

Note If using ModelVision in DEMONSTRATION mode, the gravity data points have 
been included in the loaded TUTE5.SES session file. 

 
The gravity data is similar to that below: 

POINT X Y Elev ObsGrav  FreeAir Boug2.67 
1000 290317.813 6567573.000 287.12 9793745.22 29.27 -291.94 
1000 285590.000 6590143.000 225.25 9793607.75 11.51 -240.49 
1000 285317.688 6583827.000 242.32 9793674.09 29.44 -241.65 
1000 289011.313 6562047.000 262.74 9793678.59 8.42 -285.52 
1000 287788.688 6555632.500 312.42 9793608.15 -3.48 -352.99 
1000 288908.688 6596862.000 320.04 9793491.49 -37.59 -395.63 
1000 290597.313 6602272.000 330.10 9793354.62 -107.01 -476.30 
1000 291605.000 6606471.500 376.73 9793208.64 -62.78 -484.24 
1000 290722.375 6611583.500 431.90 9793254.97 181.96 -301.22 
1000 289273.375 6617146.000 680.92 9792786.62 490.13 -271.63 
1000 288612.625 6574692.000 646.48 9792832.84 442.14 -281.10 
1000 340526.375 6615288.000 644.65 9792760.40 384.15 -337.04 
1000 339921.000 6613413.500 351.74 9793290.48 126.69 -266.81 
1000 337533.188 6614768.500 366.37 9793261.87 68.35 -341.52 
1000 336478.188 6613494.500 427.63 9793227.25 167.20 -311.20 
1000 351114.813 6609526.500 357.84 9793556.12 -38.64 -438.97 
1000 348149.125 6610414.500 319.03 9793811.86 86.40 -270.51 
1000 353535.125 6605875.000 312.31 9793813.76 79.57 -269.82 
1000 357612.813 6603559.000 302.99 9793829.17 78.22 -260.74 
1000 335965.188 6603374.000 297.73 9793827.17 72.00 -261.08 

 
After importing, examine the statistics using Utility>Statistics>Points Data menu option. 
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Step 4 

You may wish to display the data at the imported points with the airborne data grid to 
determine the two data coverages. However in this tutorial the points will be displayed in a 
separate map window. Select View>Map>Points and in the Points Selection dialog that 
appears move the only available points group in the Available list to the Selected list and 
click OK.  

Configure the point data by modulating the colour and size in relation to the Bouguer 2.67 
data values. Use the Points Set layer in the Map Layers table to alter the points 
appearance according to the below image. 

 

You will see after configuring the points appropriately, the locations of the regional gravity 
stations. 

Step 5 

To compare the gravity data with the magnetics in grid image form, create a grid from the 
gravity data points using the Utility>Grid Channel Data option. Grid the gravity points 
Bouguer data (Channel Boug267) using a 200 metre sampling interval.  
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Note To grid the points data, you will need to select the Point mode option in the top left 
corner of the Grid Channel Data dialog as illustrated above. 

 
Display the newly created grid image in a different display window by using the 
View>Map>Grid Image menu option. Add the Bouguer gravity points (refer to Step 4 above) 
as constant point size and constant square symbol colour. 

Step 6 

You can co-sample the reworked gravity data to the same locations as the aeromagnetic 
data and hence creating a gravity channel in the aeromagnetic by the following method.  

Access the Utility>Sample From Grid menu option. Nominate the lines onto which the grid 
data is to be interpolated, specify the grid and output channel name and click the OK button. 
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Redisplay the stacked profiles with both the magnetics and grid-interpolated gravity data 
(select View>Stacked Profile menu option). For modelling or regional purposes, you may 
want to rename the BOUG2.67 gravity channel to GRAV (using the Utility>Data 
Maintenance>Line>Channel Maintenance option.  

Note This approach could also be used to interpolate elevation, or any other data type 
from a grid to individual readings along a line. 

 

 

 



 ModelVision Tutorials 69 

Tutorial 6 – Regionals and Advanced Modelling 

Aim 

The aim of this tutorial is to illustrate the various presentation formats available and to 
introduce the concepts of multi-line displays, grids and modelling.  

Geologically, the area contains a complex area with a number of steeply dipping interbedded 
volcanics trending north-south (to NNE-SSW). In some instances, the units are faulted 
typically with NE-SW trending structures. Granitic intrusions are evident within the data and 
these are typified by low internal magnetic responses. Surrounding these intrusives are 
magnetic aureoles and demagnetizing affects associated with intersected volcanics. 

The aim of modelling and the analysis here is to identify and investigate anomalous features 
within the data, identify structures and provide mapping information. In particular, anomalies 
lying adjacent to the granitic margins are of interest since these are known sites of tin 
deposits associated with heavy metal mineralization. 

Intended User Level 

Medium and experienced users. Advanced modelling. 

Topics Covered 

• Data Import 

• Grid generation and grid import 

• Display formats 

• Regional grid generation 

• Multi line modelling 

• Introduction to advanced modelling 

Note In DEMO mode you cannot import your own data. You can, however, load one of 
the supplied binary session files which contain data. For access to the tutorial you 
are required to load a session file. 

Setting up the Tutorial 

Initially, ModelVision requires a project to define location, magnetic properties and a 
description of the work. ModelVision stores project information in a file (MVPROJ.INI) which 
resides in the project folder. Before any data can be imported or a session with ModelVision 
is commenced, a project must be created. 

Select the File>New>Project option and enter the information as required. Initially, select 
the Browse button and navigate to .\PROGRAM FILES\ENCOM\MVIS 
14.0\TUTORIAL\TUTE6.  

It is important at the commencement of a project that you know the location of the data to be 
used in the session. You can enter the project datum and projection information plus you can 
supply the location to derive the local Earth’s magnetic field using the IGRF tool as shown in 
the image below.  
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Tutorial Background 

The data file for this tutorial was acquired from a small airborne survey flown in 1989 in south 
western New South Wales (near West Wyalong). This survey data has been acquired with 
traverses that are oriented northeast to southwest with line spacing of 1200 metres (only 
every fourth line has been retained for this tutorial). Within the data file are Australian Metric 
Grid (AMG) coordinates (using AMG Zone 54), Fiducials, Magnetics, Altimeter and the 
spectrometer channel for Potassium (K40). The survey was over relatively flat grazing and 
intensely cultivated agricultural areas. Known granites, volcanics and metamorpohosed units 
predominate in the area with some minor basic intrusives and dyking. Extensive structural 
deformation and faulting exist in the survey coverage.  

Tutorial Steps 

The following tasks should be undertaken for this tutorial: 

Step 1 

Load the data with the File>Import>Profiles>Sep. Header (HDR & LIN) option. The data is 
located in .\PROGRAM FILES\ENCOM\MVIS 14.0\TUTORIAL\TUTE6.  

The import data file is called TUTE6.LIN but the Separate Header option uses the 
TUTE.HDR file. This import file format illustrates how large multi-column data files can be 
loaded without extensive editing of the data file. The header and data file appear as below: 

Header File 

LINE X Y FID MAG K40 ALT 

Data File 

1201 489435 6259404 18612 58158.1 91  292 
1201 489415 6259397 18613 58157.8 81  292 
1201 489396 6259390 18614 58158.4 72  292 
1201 489377 6259384 18615 58159.2 70  293 
1201 489358 6259377 18616 58159.3 68  295 
1201 489338 6259371 18617 58159.7 74  295 
1201 489319 6259364 18618 58158.5 80  296 
1201 489300 6259357 18619 58157.8 77  296 
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1201 489280 6259351 18620 58156.4 74  297 
1201 489261 6259344 18621 58155.4 70  296 
1201 489242 6259337 18622 58153.9 66  296 
1201 489222 6259331 18623 58153.2 67  297 

 
After loading the data file, examine the data ranges and statistics of the channels when the 
statistics dialog opens at the end of the import. You can analyse the statistics of any 
individual line by double clicking on the nominated line. 

Step 2 

ModelVision then opens a dialog for selection of a channel for a stacked profile map display. 
Use the View>Map>Stacked Profiles option and select the MAG data channel. Once a map 
is presented you can adjust the vertical scaling to highlight features in low gradient areas. 
This is done by selecting the Layer Table button in the main toolbar to display the Map 
Layers table and then click on the Stacked Profile layer in the table with the right mouse 
button to select the Configure pop-up menu option. Edit the vertical scaling and highlight 
features accordingly. 

 

From regional geochemical sampling, the location of an area with anomalously high tin and 
base metal associations is known (see above). The anomaly correlates with a magnetic 
trend produced by volcanics and was covered by the airborne survey along line 1500. 

Step 3 

To prepare line 1500 and the anomaly for modelling, it is necessary to setup the fields in the 
Model>Line Control dialog. Assign the field Mag to the Input Channel and use the 
altimeter channel ALT for the Sensor Z channel.  When you use the altimeter channel, the 
model depths will be in metres below the ground surface rather than absolute elevation 
above sea level. 
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There is a broad regional background trend superimposed on the data so we will need to 
remove this from the data with the regional modelling tools.  In other circumstances, a two-
dimensional regional surface can be created and used for multi-line modelling. 

Check the Use Regional checkbox and then activate the Compute Regional button.  Using 
the Active Lines button, nominate line 1500. Once selected, press OK and click the 
Compute from Data button using a polynomial order of 1. 

 

Step 4 

With the regional created, you can now display line 1500 with a track beneath to be used as 
a cross-section below the flight line (use the View>X-Section option). The displayed dialog 
allows you to select line 1500 from a pull-down list. Note also that the dialog enables 
magnetic modelling on the line and uses the regional in the computation of magnetic body 
responses. 
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Once specified, click the OK button. Line 1500 is displayed in a profile window with a cross-
sectional area beneath. This area is used to create and edit the magnetic model. The model 
response is superimposed on the regional trace (indicated by three regional ‘handles’).  

 

The location of the magnetic anomaly is at the left margin of the profile. In preparation for 
modelling, you need to zoom into the anomaly. You also need to instruct ModelVision that 
only this anomaly is to be modelled and not the whole profile.  

Step 5 

You can zoom into the target anomaly by using the zoom button, but in this case we will set 
the Zoom range manually.  Use the right mouse click to access the 
Configuration>Track1>Horizontal Range dialog. Specify the Min and Max range of the 
Distance Along Profile to be between 0.0 and 5000.0.  
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You may wish to adjust the Z range also to use more of the space provided. To adjust the 
amplitude of the profile right mouse click on the top half of the x-section window and for 
Track 1> select Fit Vertical. 

 
Make the target anomaly active for modelling and inversion by using the Active 
Points button. Select the Draw Profile Region button and position the cursor in 
the profile window at the start of the area to be modelled. Click the left mouse 
button and drag an area along the profile for modelling. Ensure the complete 
anomaly is defined with any side lobes that may affect the source modelling. 

 

After the bounding lines of the active region have been defined, release the mouse button 
and you will notice the model response curve changes colour.  

Step 6 

 
To create a model and compute a magnetic response, select the Create Body 
button. As the geological source is not defined, the simplest body type should be 
used initially. From the Create Body dialog, select the Tabular body.  

 

Note that the dialog displays the current default properties that will be assigned to the body 
and a preview of the body style. Once the tabular body has been selected, position the 
cursor in the profile cross-section, click the left mouse button and drag a rectangle that will 
form the body outline. When the button is released, the body is created. 

 
You can display the magnetic response due to the created tabular body by 
clicking on the Compute button.  

Only the response along the nominated active points of line 1500 is computed as no other 
readings in the dataset have been selected as active. To adjust the display depth for the x-
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section window right mouse click in the bottom half of the display and select the Track 0> 
Vertical Range pop-up menu option that appears. Adjust the maximum Z Range to 2000m. 

 

Step 7 

 

 

   

Initially, the body location and orientation is unlikely to be correct for a match 
between the computed magnetic response and the observed data. You can edit 
the body, magnetic susceptibility and regional until you get an approximate match 
between the model response and the original data.. After each edit you can force 
ModelVision to update the computed response by toggling the Manual/Immediate 
mode of computation.  

 

 

The tabular body can be positioned by selecting with the cursor and locating as 
appropriate. Its width can also be modified interactively by selecting a corner 
handle and dragging. You need to have ModelVision in the Pointer mode for 
these operations (select the Point icon or button). By using the Reshape button 
you can edit the dip of the body.  

Modify the location and orientation until there is a close match to the anomaly shape. You 
will also need to adjust the magnetic susceptibility to obtain an amplitude match. Note that 
there is a level shift between the observed and theoretical traces.  You can select the left 
had regional handle and drag it down so that the shift is minimised. The fastest methods of 
removing the level difference and improving the model fit is to use inversion. 
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Step 8 

The use of inversion in ModelVision is a powerful tool for rapidly refining 
models.  

To initiate inversion, select the Tools>Inversion option (or click the 
right mouse button when the cursor is in the ModelVision screen 
window). The Inversion toolbar is displayed and can be 
positioned on the screen. 

Note that you are using standard inversion rather than join 
inversion for this tutorial. 

The tabular body type is defined by a set of parameters, each of which 
can be freed during inversion. The more parameters that are set free, 
the easier it is to get a match with the field data.  This is not 
generally the best approach because the smallest number of free 
parameters provides the optimum approach.  This process lets you 
evaluate the maximum geological information that you can infer from the magnetic anomaly.   

The logical order for constraining a tabular body magnetic inversion is as follows: 

DC regional 
Position (distance) or X, Y 
Magnetic susceptibility 
Depth 
Thickness 
Dip 
Regional gradient  
Depth extent. 

The azimuth and strike length are normally determined by inspection of the map.  Note also 
that magnetic susceptibility and thickness trade off against each other during inversion and 
unless the body thickness is greater than its depth, it is not possible to uniquely resolve 
either property. 

Select the Free button to open the Free Parameters dialog and set the Regional Level 
check box to on and then Run the inversion. You will see a minor shift in the regional trace.  

 

Note that the Select Bodies item at the top of the Free Parameters dialog is set to ALL. In 
this case, only one body exists but in more complex cases where additional bodies may be 
present, you can individually select the body and its free parameters.  Set the Distance 
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(position along the section), Z (depth) and Property (susceptibility) free and run the inversion.  
There will still be a significant mismatch in the model and field data. 

Now free Thickness and run inversion again.  If the Inversion Messages dialog indicates that 
thickness is being constrained too tightly, then you can use the Toler. Dialog to increase the 
constraints. 

  

 

Step 9 

You may need to perform a few Runs of the inversion to optimally fit the theoretical and 
observed response curves. If the appropriate parameters are freed sequentially, a good fit 
between the curves can be achieved quickly. This approach can save considerable time in 
evaluating even complex anomalies. 

The final match between the modelled and observed magnetic responses is shown below. 
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Tutorial 7 – Modelling, Regionals and AutoMag 

Aim 

The aim of this tutorial is to introduce the depth-to-basement option known as AutoMag. The 
ease of use and rapid interpretation is illustrated by the fast analysis of a relatively large 
dataset. 

Note This tutorial uses a ModelVision option called AutoMag. Unless you have access 
to this option, you will not be able proceed with this tutorial. It is possible to 
access the option and data if ModelVision operates in Demonstration Mode. 

 
If you have a licensed version of ModelVision which is UNLICENSED to operate AutoMag, 
the option will not operate unless a valid demonstration session file is accessed (for this 
tutorial, TUTE7.SES). This provides you with the ability to experiment and evaluate 
AutoMag, but only on supplied, demonstration datasets. 

Intended User Level 

Medium and experienced users. Advanced options. 

Topics Covered 

• Data Import 

• Noise removal 

• Display formats 

• Regional grid generation 

• AutoMag 

Background Information 

The dataset to be used is from a segment of a larger airborne survey acquired in 1993 from 
Western Australia. There was considerable noise in the magnetic channels caused by the 
low altitude of acquisition (50 metres AGL) and surface maghemite known to be present in 
this area. The data has therefore been upward continued 50 metres to smooth the magnetic 
response. It is important to take note of this operation, since depths derived from the 
AutoMag option will need to take this additional 50 metre height offset into account. 

Tutorial Data 

Initially, a project is required to define the various properties of the data. ModelVision uses 
projects to manage various analysis exercises and a MVPROJ.INI records your entries for 
later use. Binary session files (.SES) can also be used to store data, models and displays if 
required. 

The contents of file TUTE7.LIN and its associated files are used in this tutorial and can be 
accessed from .\PROGRAM FILES\ENCOM\MVIS 14.0\TUTORIALS\TUTE7. 

Note that if ModelVision is being used in Demonstration mode, you can load the data from 
the TUTE7.SES file using the File>Open>Session menu option.  

This tutorial presents an overview of the ModelVision option, AutoMag. It provides an 
understanding of the principles involved in using AutoMag for a rapid depth-to-basement 
analysis of data. 
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AutoMag Background 

Depth to magnetic source calculations have occupied geophysicists for months and years 
depending upon the scale and objectives of their interpretational project. Manual techniques 
such as the Straight Slope method and Peter’s Length have been used for depth estimation 
for many decades. These procedures are mechanical, repetitive and time consuming but 
require a skilled geophysicist to reject inappropriate magnetic anomalies. 

Manual methods are still used today because they produce consistent results with judicious 
rejection of spurious anomalies. Computer procedures for automatic depth interpretation 
have become increasingly popular to supplement manual procedures. One such procedure 
that has become popular over the last five years is the Euler 2D method. These methods 
work well as a first pass assessment of the magnetic source distribution, but lack the critical 
input of the interpreter in rejecting spurious solutions. Invariably there are too many solutions 
and the relationship between the magnetic anomaly and an individual solution is unclear. 

Manual methods are time consuming but produce geologically constrained solutions while 
fully automated methods lack the critical intervention of the geophysical interpreter. AutoMag 
bridges this gap by providing a consistent automated process that reduces the manual 
intervention and provides the interpreter with the ability to quickly test any solution against 
forward model solutions. Interpreted depths can be plotted in cross-section, map view or 
exported to an ASCII file for use in another application. Depths from the AutoMag solutions 
can be gridded to produce a contoured map of ‘depth to basement’. 

Tutorial Steps 

The following tasks should be undertaken for this tutorial: 

Step 1 

Unless loading the TUTE7.SES session file, create a project for the tutorial (using 
File>New>Project). The information required for the project is: 

Datum     AGD66 
Projection    TMAMG55 
Magnetic Field    58200 nT 
Field Inclination   - 59 degrees 
Field Declination   9 degrees 

 

Refer to tutorials 3,4 or 6 for additional information on creating a ModelVision project. 
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Load the supplied LIN format file (TUTE7.LIN) using the File>Import>Profiles>Simple 
XYZ format (.LIN) format menu option (or the TUTE7.SES session file if operating 
ModelVision in Demonstration mode).  

The data contained in this file has a header and format similar to that below: 

LINE X Y MAG 
1000 488008.000 6254576.000 58157.699 
1000 488029.000 6254583.000 58158.398 
1000 488050.000 6254590.000 58158.199 
1000 488071.000 6254597.000 58158.602 
1000 488092.000 6254604.000 58158.699 
1000 488113.000 6254611.000 58159.398 
1000 488134.000 6254618.000 58158.801 
1000 488155.000 6254625.000 58159.898 
1000 488176.000 6254632.000 58158.398 
1000 488197.000 6254639.000 58159.102 
1000 488218.000 6254646.000 58158.602 
1000 488239.000 6254653.000 58158.301 
1000 488260.000 6254660.000 58157.801 
1000 488280.000 6254667.000 58157.102 
1000 488301.000 6254674.000 58157.000 
1000 488322.000 6254681.000 58157.102 

 
The line statistics menu will open automatically and you can see that a large number of data 
lines are present and that the total survey distance covered by the data was 112 kilometres 
with an average sampling of 20 metres between readings. 

 

When you close the dialog, you will see an option to display a stacked profile map. 
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Step 2 

Create a Multi-Track of the magnetics channel (use the View>Multi-Track option). (For 
information on Multi-Track displays, refer to Tutorial 2.) If you zoom in you will notice that a 
high degree of noise is contained in the data. The noise is derived from a combination of 
near-surface geological noise as well as instrumental noise. (The figures below are for line 
870.) 

 

Prior to the use of AutoMag we will reduce the impact of some of the high frequency noise. A 
simple but effective way of doing this is to upward continue the data.  The upward 
continuation height can be subtracted from the depths. Create a FFT filter of say 25, 50 and 
100 metre upward continuations and apply it to all lines Name the output channels as 
MAG_FUC25, MAG_FUC50 etc. Compare these in a Multi-Track display for Line 870. 
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From this analysis, noise is barely noticeable with an upward continuation height of 25 
metres and negligible for 50 and 100 metres. Select the 25 metre upward continuation 
height.  

Step 3 

Review the data by displaying a stacked profile map of the MAG_FUC25 channel.  

 

Another method of reviewing the data is by a contour or image display. You can import the 
grid (TUTE7.ERS) which is supplied in ER Mapper format, or you can grid the data yourself. 
Review Tutorial 3 for an overview on gridding and image/contour displays. 

Step 4 

From the gridded data you will note that a southwest to northeast gradient is present in the 
data. This will need to be taken into account for modelling and AutoMag. To create a 
Regional channel, first make sure that the MAG_FUC25 channel is chosen as the Input 
Channel in the Model>Line Control menu option. 
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Select the Model>Edit Regional>Magnetics option. From experimentation a 2nd or 3rd order 
polynomial seems to be most appropriate to represent the original field for this data.  

 

You will need to set all of the lines available to be Active (use the Active Lines button) to 
enable all data to be used for the computation of the Regional surface. When selected, 
compute the Regional with the Compute From Data button using a 2nd order polynomial on 
the MAG_FUC25 channel. 

You can add the regional (MAG_REGIONAL) as a new stacked profile on the existing 
stacked profile map. Change the colour to blue to see the contrast between the original data 
and computed regional. 
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Step 5 

Grid the data at 50m (Utility>Grid Channel Data) and use the Expert Params button to set 
the iterations to 1000. 

 

Display the grid with a contour overlay.  
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Note that the central and southern portion of the data is dominated by two elongate 
anomalies (from dyke sources?) and a third source/structure lies between the two. The initial 
phase of operating with AutoMag is to select a line which is representative of the geological 
regime to be interpreted. This line will be used to ‘train’ the AutoMag parameters. When 
depth solutions are satisfactory, these parameters can then be applied to all the other 
required lines. Line 860 can be selected as appropriate for our purpose. 

Step 6 

Use the View>X-Section option to present the line cross-section. When this line is selected 
it will automatically become active for modelling. Turn on the Configure Layers menu using 
the right-click pull down menu and turn on Orientation Labels, Line Name and Track Titles.  

 

Usually this profile form of display is used for model creation. With AutoMag it is used to 
display and checking the various AutoMag solutions and for selection of the various 
AutoMag parameters. 

Step 7 Optional Tuning with Quick Invert 

One of the more difficult parts of using AutoMag is the choosing of best tuning parameters. 
To help with this, it is possible to use QuickInvert on a representative anomaly and have the 
appropriate parameters automatically taken into AutoMag.  You can go straight to Step 9 if 
you want to skip the QuickInvert process. 

Before stating AutoMag, choose a representative anomaly such as the one at station 1750 
on Line 860 and have it displayed in the X-Section window.  Make sure this window is active. 
Choose the menu Model>Quick Inversion or click on the Quick Invert icon.  This tutorial is 
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not focused on inversion, so use this segment of the tutorial to learn how you can use 
QuickInvert to set the starting parameters. See Tutorial 8 for more detail on Inversion. 

In the Quick Inversion dialog box, select the Seed tab and make sure the upward continued 
grid is selected (MAG_FUC25) and the local regional is unchecked. Check the 1VD 
checkbox and a first vertical derivate curve will appear in a new track above the total 
magnetic field track. 

 

Click Create Seed. You will be asked to drag out a region in the cross section window.  Click 
OK and drag out a region which is approximately the width between the low on each side of 
the first vertical derivative curve.  

 

A seed body will be created and displayed in the section. 
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The seed body is roughly in the correct location and has a similar anomaly amplitude to the 
field data.  If an error message is generated and a poor fit, then drag the body into 
approximately the right location prior to starting inversion. 

Check options Suscept, Position, Depth, Width and Dip. Uncheck Depth extent and enter 
2000. Enter 1000 for Strike extent and click Apply to Body. You are now ready to invert. 
This will perform 3 Iterations (as specified in the iterations box) and get close to a solution 
which matches the 1VD curve.  Invert several times until you get no further improvement. 

 

If the match is not good, click on Delete Body and then start this step again. 

Finally, click the AutoMag button. This will not only start AutoMag but also copy the depth 
and width values into the AutoMag Run dialog.   

Step 8 

If you have existing model bodies, you should save them to a model file Model>Export>MV 
Pro Format. If you use the Kill Bodies on the AutoMag toolbar, you will delete all existing 
bodies as well as AutoMag created bodies.  

Step 9 

If you have not done the Quick Inversion step, start AutoMag by selecting the menu option, 
Modules>AutoMag.  

Warning If AutoMag will not operate, you will need to load the data from the TUTE7.SES 
session file. Refer to the Warning at the start of this Tutorial. 

 
You will notice the AutoMag toolbar displays (see image below). With the line displayed, 
select the Run option and the AutoMag control dialog displays as illustrated below. 
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The survey line separation for this survey is approximately 200 metres. The default for 
AutoMag strike lengths are set to 1,000 metres. Alter this to 400-500 metres. Change the 
dyke depth (top) to 125 and width to 110 which are the approximate values derived from the 
Quick Invert process.  If you did not do this then using the defaults of 100 would suffice for 
now. Select OK and run AutoMag on this line only.  In this example, the AutoMag solution 
closely matches the trial anomaly and a second solution is shown on the right hand end of 
the section. 

 

AutoMag derives depths using bodies of infinite strike length. A specified strike length is only 
for convenience in giving that value to bodies created from the solutions.  

After you have completed the AutoMag tuning, activated all data points for the line using the 
Active Points toolbar button followed by the Select All in the Active Points dialog. 

Parameter Setting 

Points to note in setting the AutoMag parameters are: 

• The Sample Spacing is reported by ModelVision automatically. 

• The number of Depth Passes is usually set at 3-4 since this provides for a reasonable 
range of operator width in the solution computation. 

• The best guide to setting the Window size is to examine the anomaly widths of the 
profile data being interpreted. The ideal Window Size will span the minimum and 
maximum amplitude points of an anomaly. This window setting is best addressed for 
central depth passes. Note also that if you alter the Window Size to be measured in 
Samples rather than metres, the best starting point will be approximately 25. This 
value is derived from the Sample Spacing. 

• The Similarity Coefficient Cutoff is the threshold value below which AutoMag will 
attempt to isolate the anomaly. If the similarity coefficient is below the specified value, 
AutoMag searches for a local similarity coefficient minimum. AutoMag will then use 
this location as the centre of the window for performing a detailed analysis of the data 
within the window. 

• Initially do not be concerned by the Depth Estimation parameters. Refer to Single 
Anomaly Tutorial in the User Guide for more detail on manual setting the tuning 
parameters.. 

Step 10 

In this step we will look at the display of similarity coefficient and dynamic filtering of the 
AutoMag solutions to remove lower quality solutions. Since the initial setting derived from the 
QuickInvert settings were excellent, we need to change the default similarity coefficient 
threshold settings to demonstrate the filter behaviour. Set the similarity cutoff defaults of 450 
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and 400 rather than the 350 and 280 default values. The higher thresholds locate more 
minima as shown in the cross-section below. 

When the various AutoMag parameters have been entered, select OK and the AutoMag 
module will execute. A speed bar will be presented and after completion will report on a 
number of solutions. When OK is selected, the solutions derived will be displayed on the 
cross-section.  

Display the Similarity Coefficients by displaying the Cross Section Layers table and 
selecting the Add>AutoMag Coefficients from the pop-up menu that appears when any 
layer is clicked on with the right mouse button. 

 

On pressing OK, tracks appear at the top of the data to indicate the similarity coefficients for 
the various window computation passes. 

 

In the event that too few solutions have been computed, position the cursor beneath the 
minima of anomalies on which you feel a solution should have been computed. Read the 
cutoff coefficient value (this is displayed in the status bar at the base of the ModelVision 
screen). To adjust the number of solutions, revise the coefficient cutoffs in the AutoMag 
Run dialog. Increasing the similarity cutoff will allow more solutions to pass. Reducing the 
level will reduce the number of solutions. 

When a new similarity value has been entered, re-run AutoMag to create a new set of 
solutions. It is probably better to choose a higher similarity cutoff and generate more 
solutions (as shown) and then use the Filter (see below) to quickly determine an appropriate 
cutoff value. 
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Step 11 

Each solution has physical properties assigned to it based on the chosen model (in this case 
a dyke).  If the similarity coefficient cutoff is chosen too high, solutions will be determined for 
parts of the curve which might be noise or other artefacts.  In addition, some solutions may 
be generated where a dyke model is inappropriate. To get rid of unwanted solutions, you can 
use the Filter option on the AutoMag tool bar. 

 

Having the Auto Display option checked allows changes to parameters to be displayed in 
real time.  The visibility of solutions is turned on and off as solutions fall within or outside the 
filter parameters. 

Clicking Reset sets all filter parameters back to their initial values. 

Dip 
For a dyke model, dips shallower than 20-30 are probably inappropriate and are probably 
more appropriate to edge solutions. You can view which solutions are shallow by entering 
say 20 in the Max side and seeing which ones are left.  To remove these, enter 20 in the Min 
and make the Max 90.  In this case enter 30 in the Min side. 

Thickness 
Extra wide dykes are probably inappropriate so you may wish to reduce the Max width. In 
this case, remove widths greater than 1000m by entering 1000 in the Max. 

Suscept 
You sometimes get negative susceptibilities.  These are often the result of picking the low 
between two closely spaced anomalies.  You can check which solutions have negative 
susceptibilities by entering zero in the Max side. In this case we will remove all solutions with 
negative susceptibilities, so enter zero in the Min. 

Level 
This is the similarity coefficient pass number. You can filter out solutions for pass numbers 
that you do not want. In this case we will leave this as is. 

SimCoeff(A) and SimCoeff(D) 
Use the slider to reduce the similarity coefficients until you have only a couple solutions. This 
is a tuning exercise so you should choose the largest similarity coefficients that still give 
reasonable solutions.  In this case, you will need to find your own optimum but err on the 
side of making it greater than smaller.  When you apply this slide, think about what is 
geological reasonable. 

For now, leave the Confidence and Correction Angle unchecked. 
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Confidence and Correction angle 
These sliders are only used when you have a strike angle correction grid which is not the 
case in this tutorial.  See the AutoMag documentation for information on how to create and 
use the strike angle correction method. 

Group Filter 
This filter detects near coincident solutions which may occur on the same pass or multiple 
depth passes.  A window size is selected automatically by AutoMag and you use the slider to 
change the effective size of the window as a percentage of the initial size.  As soon as you 
turn on this filter, some solutions will disappear.  Any solutions found within the window 
group are analysed for the best similarity coefficient and if very close, the shallower solution 
will be used.  The secondary susceptibility filter is used to reject extremes 

Experiment with each filter on an individual basis to see how it behaves before combining 
them in a geologically sensible manner.  The logical order for application of the filters is as 
follows: 

Dip (>30) 
Susceptibility (>0) 
Simcoef (D) (<300 generally) 
Window 

Note After you have the filter parameters set as you wish, you must then click Apply 
Filter for the actual filter to be applied.  If you close the filter dialog before Apply 
then all solutions will be retained. 

 
If you wish, you can save the filter parameters by clicking Save and later bring them back 
using Restore. 

Step 12 

Not all solutions derived will be satisfactory. Solutions contain information on the physical 
properties of the body type requested - in this case a dyke. Hence, thickness, dip, 
susceptibility etc will have been computed for each solution. 

To test if a solution is viable, select the solution box with a mouse click and then convert it 
into a body by pressing the Space Bar. You can also do this with the Point  Body toolbar 
button. The solution will be converted into a dyke (tabular body) with computed properties. 
After this has been done for a selected number of bodies, the Compute toolbar button can 
be used to forward model the response and check against the observed data (unless the 
Immediate Compute button is already active). 

 

In most instances the solution is likely to be reasonable and so it can be kept. In a few cases 
the solution will be unreasonable and can be rejected. To do this simply select and Delete. 
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Step 13 

Once you are satisfied that the AutoMag parameters derived from the analysis for this line 
are satisfactory, you can apply these same parameters to an AutoMag computation of the 
entire dataset.  

Open a map window and display a contour map of the filtered grid plus 
the flight lines.  When you Run AutoMag from the toolbar, you will be able 
to select all of the lines from the Selected Lines button. You can 
activate a subset of lines using the AutoMag Active Lines toolbar option.  

Place the cursor at the top of the display and with a left mouse click, 
drag and draw the ‘rubber-band’ over all the data lines to be made active for AutoMag 
computation. 

After the Active-Line ‘rubber band’ has crossed the various lines, they will display as a thick 
line indicating they are now active for AutoMag operation. 

Step 14 

Again select the Run option from the AutoMag toolbar. Leave the parameters as they have 
been set from the ‘training’ line. Run the AutoMag option by selecting OK. AutoMag will now 
operate sequentially on all the selected active lines. This may take some time but is relatively 
fast. 

When the computation is completed, you will see the derived solutions displayed in the 
contour window. From comparison with stacked profiles or field contours you can determine 
from which feature of the field variation each solution has been derived. Solutions can be 
selected and deleted in map views as well as section displays. 

 

You should again run the Filter to remove poor solutions. 
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After the filter, some of the computed solutions may require editing or deletion. This can be 
done either in the Map or in X-Section windows by selecting the solutions and pressing the 
Delete key. 

Step 15 

Depth estimates derived from line data are based on the assumption that the target geology 
is trending perpendicular to the flight lines. If a profile crosses a feature obliquely, the 
magnetic anomaly is stretched which increases the apparent depth of the target. AutoMag 
provides manual and automated methods for strike correction.   

To perform strike correction manually, solutions must be selected sequentially along strike. 
The SHIFT key is depressed while the solutions are selected. When you finish, select Adjust 
Trend from the AutoMag toolbar and then the Sequential Points checkbox.  

 

This will immediately adjust the depth values of the AutoMag points.  To see the values in 
map view, use the Channel Annotation button which is access from the Map Layer>AutoMag 
Solutions layer. The example below shows annotated depths with the right hand trend has 
been manually depth corrected. 
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To perform the automatic strike correction, a trend grid must first be created. Click Adjust 
Trend on the AutoMag toolbar and select the Trend Grid option. 

 

Click on the Create button and select the MAG_FUC25 grid used for the trend analysis.  You 
can also run the trend analysis from the AutoMag Run dialog and the menu Utility>Grid 
Utility>Trend. In the latter case you will need to manually import the trend grid. 

The GridUtility application will open the trend grid function and the selected grid.  Click Save 
As… and give the multi-channel grid the following name: MAG_FUC25_Trend.ers. The two 
grids MAG_FUC25_Trend and MAG_FUC25_Confidence will open automatically in their 
own map windows. 

You will need to close the Adjust Trend dialog and reopen it to refresh the list of grids.  
Once the trend and confidence grids have been created, you can use them each time you 
run the AutoMag dialog by turning on the Apply strike correction checkbox. Make sure you 
select the MAG_FUC25_Trend grid from the pull-down list. 

You can clean up poor solutions where the trend azimuth derived from the grid was poor.  If 
the angular correction is significant (>30 degrees), then the depths will appear shallower 
than the immediate neighbours.  You can delete these solutions, or convert them to bodies 
and use inversion to refine the depths. 

Step 16 

Select all solutions in map view and use Pt->Body to generate model bodies from the 
AutoMag solutions.  The map below shows the location of the tabular bodies derived from 
the AutoMag solutions with corrected depth below sensor values (DEPTHC).  If sensor 
elevation data is included 

The bodies create are best viewed in Perspective view to look for anomalous or erroneous 
bodies. 
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You can correct the depths for flying height and upward continuation so that you have depth 
below ground. 

The table below lists the fields available from each AutoMag point. Note that depth is positive 
down and changes meaning according to the information provided in the Model>Line Control 
dialog.  If sensor elevation (SENSOR) and DTM (TOPO) is provided as input channels for 
modelling, then this information is used to compute depths relative to sea level. 

Note also that where C is appended to the channel name, then it means that it has been 
azimuth corrected.  When BG is include in the name, this means below ground depth.  This 
information takes into account both the sensor elevation and dtm for computing the local 
depth below terrain.  If the sensor elevation is provided as an altimeter value, then the dtm is 
assumed to be zero and the depth below ground is computed by subtraction of the sensor 
height from the computed depth. 

Name Description 
X X value (usually Easting) 
Y Y value (usually Northing) 
BTYPE Body type (1=dyke) 
DEPTHBGC Dyke depth below ground - Corrected 
ELEVC Elevation of dyke - Corrected 
DEPTHC Depth to top of dyke (from datum) - Corrected 
SUSC Susceptibility 
DIPAZIMC Dip Azimuth of dyke - Corrected 
DIPC Dip of dyke - Corrected 
HALFWC Dyke half width - Corrected 
TRENDCONF Trend grid confidence value 
CORRANG Trend grid correction angle 
DEPTHBG Depth below ground 
ELEV Elevation of the dyke 
DEPTH Depth to top of dyke (from datum) 
SUSA Magnetic susceptibility 
DIPAZIM Dip Azimuth of dyke 
DIPA Dip of dyke 
DPTHXTNT Depth extent of dyke 
STRIKELEN Strike length of dyke 
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HALFW Half width of dyke 
TOPO Topographic elevation 
SENSOR Sensor Elevation 
SCOEFD Similarity coefficient for the Depth determination 
SCOEFA Similarity coefficient for the Anomaly location 
CODE Solution Quality Code Value 
LEVEL Depth pass number 
AZIMUTH Dip Azimuth of dyke 
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Tutorial 8 – 2D and 3D Modelling and Inversion 

Aim 

The aim of this tutorial is to introduce: 

• Synthetic survey line data simulation and survey design 

• Inversion in two and three dimensions 

Intended User Level 

Medium and experienced users. Advanced options for inversion. 

Topics Covered 

• Grid Import 

• Line creation 

• Display formats 

• Modelling 

• Two dimensional inversion 

• Three dimensional inversion 

Background Information 

An airborne geophysics survey was undertaken in the Esperance area of Western Australia 
in search of evidence of mineral sands known to exist in strandlines in the region. In many 
cases the depth to basement is important in this exploration process. To search for the low 
amplitude magnetic responses associated with mineral sand accumulation, it is necessary to 
remove the effects of basement anomalies. Continued exploration for mineral sands in the 
region would require access to the magnetic line data. This is not the intent of the tutorial, 
but to define the basement features only. 

The only data available to carry out the basement analysis is the airborne magnetic grid 
data. In this case it is necessary to create a series of synthetic survey lines which will be 
used for modelling and inversion. 

Tutorial Data 

File TUTE8.GRD (..\TUTORIALS\TUTE8) contains a small segment of a larger grid 
extracted from an aeromagnetic survey undertaken in southern Western Australia, near the 
town of Esperance. The grid is in Geosoft format and defines a linear magnetic high that is 
broken into a series of magnetic anomalies. The intention of this tutorial is to interpret the 
varying depths of magnetic sources along this trend and in so doing, introduce some of the 
concepts associated with inversion. 

Tutorial Steps 

The following steps should be undertaken for this tutorial: 

Step 1 

Initially, a project is required to define the various properties of the data. ModelVision uses 
projects to manage various analysis exercises and a MVPROJ.INI records your entries for 
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later use. Binary session files (.SES) can also be used to store data, models and displays if 
required. 

Select the File>New>Project option and enter the information as required. For this area and 
projection information includes: 

Datum:  Australian Geodetic Datum 1966 (AGD66) 
Projection: Transverse Mercator 
Zone:  AMG Zone 49 (TMAMG49) 

Note that the entries for the Earth’s magnetic field are set to be: 

Field Intensity : 59980 
Inclination: -58.5 degrees 
Declination: 9 degrees East 

The project properties dialog should look like this: 

 

Load the available Geosoft format grid (TUTE8.GRD) using the File>Import>Grid>Geosoft 
option (or the TUTE8.SES session file if operating ModelVision in Demonstration mode). On 
import and image of the grid will be generated automatically. 

From reviewing the Utility>Statistics>Grid Data option, note that the grid has mesh size of 
20 metres and the data contained in the grid is for the total magnetic field. 
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Step 2 

In the Grid Data Statistics dialog the imported grid will be called GRID. Access the 
Utility>Data Maintenance>Grid menu option and rename it to MAG by clicking on the 
Rename button and entering the new name. Click OK to exit this dialog. 

Step 3 

Add a contour display of the imported grid data and set the contour interval to 5, the image 
illumination light source azimuth to 90 and the image decimation to 3. Note that the grid 
defines the north-west trend well and is broken into four discrete anomalies. For this 
exercise, we will assume the magnetic feature defines a series of discrete magnetic sources 
along a common trend. 

 

Step 4 

We will use the Utility>Synthetic Lines menu option to create the synthetic survey.  Note 
also that you can generate arbitrary lines from the grid using the Traverse button. 

Open the Utility>Synthetic Lines dialog. Note in the entries that the survey centre (Ref. pt) 
is defined and then the line width and survey width (or height) define the survey dimensions. 
Make sure that the Clip check box is off for this exercise so that you can set the line length 
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and survey height (Width).  If Clip is on, then the lines will automatically be truncated at the 
boundary of the displayed grid.  Set the parameters as shown in the dialog below. 

 

Use the Create Survey to generate the initial set of survey lines.  This will create a set of 
flight lines with an elevation channel with constant terrain clearance of 80m. 

 

If you are not happy with the location of the lines, then change the change the dialog 
parameters, delete the current set of lines and then run Create Survey again.  If you forget 
to delete the previous lines, they become permanent and you must use the Line 
Maintenance option to delete them. 

Step 5 

You can sample the grid data onto the synthetic lines using the menu function 
Utility>Sample from Grid or the Utility>Calculator in grid interpolation mode: 

a) Utility>Sample from Grid 
Select the synthetic lines on the left and the nominated grid (MAG) on the right. Enter the 
channel name that will be exported as the new field on each line. 
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b) Utility>Calculator using the GINT function 
Open the Utility>Calculator option, check Line mode and enter the following formula: 

mag = gint(h_mag, east, nrth) 

Note that the formula is not case sensitive. 

 

In this case, the derived magnetic data values are interpolated from the ‘mag’ input grid 
(indicated by the h_grid syntax convention) and at the locations defined by the EAST and 
NRTH channels. 

Step 6 

As each data reading on the synthetic lines now has a data value, they can be displayed as 
well as modelled. Add a stacked profile map to the window, but turn off the image display to 
make it easier to see. 
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You can alter the default vertical scaling, colour and line thickness of the stacked profile from 
the map configuration menu. 

Step 7 

We will use a regional magnetic field to remove the background prior to modelling. Open the 
Model>Edit Regional>Magnetics option, select a first order polynomial and make all lines 
active (from the Active Lines button within this dialog). Press the Compute From Data 
button and a regional surface will be created. 

 

Note that you should always use the lowest possible order that removes only the long 
wavelength features that are not part of the geological problem your are trying to solve. 

Step 8 

Select the Model>Line Control menu option and ensure that the MAG field is selected for 
the Input Channel, the Use Regional check box is selected, the Use Sensor Elevation 
check box is selected and Elev is selected as sensor elevation channel.  Use Select Lines 
to active all lines in the dataset for modelling. 

Step 9 

Select and display the 4th data line (L04) using the View>X-Section menu option. Note that 
the observed data (created from the MAG grid), the regional trace and the model response 
(conforming to the regional line) and are all displayed. In this cross section create a tabular 
body using the Create Body button on the toolbar or the Model>Body Operations>Create 
Body menu option. 
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As you create the body in the cross section, you will note it also is displayed in the contour 
map. 

 

In a map window you may need to alter the strike length (700m), azimuth (350 or -10 deg) 
and position slightly to straddle the top two or three data traverses as we will use this body to 
model these lines concurrently. To perform this action double click on the left mouse button 
while the cursor is positioned over the body to view the Body Properties dialog.  Adjust the 
magnetic susceptibility, depth and position until you get an approximate data match as 
shown above.  In this example the regional is too high and the width of the body and depth 
are only approximate.  Inversion will allow us to get much closer. 

Continue adding tabular bodies in the map window along the main anomalies. We only need 
to use tabular for this study to estimate the depth to basement. In the map window, use the 
Reshape toolbar button to interactively change the azimuth and strike length of each tabular 
body. 

 

Change the scale of the stacked profile of the Mag channel in the map configuration layer 
control to ensure there is sufficient dynamic range to see minor changes in the data. The 
bodies obscure the stacked profile and you can change this by changing the body display 
mode to wire frame or change the body order from the map window configuration layer 
control. You access this control from a right click and selection of Window>Drawing Order 
menu option.  Select Body and move it down the list until it sits below the Stacked Profile 
Object Type. 



 ModelVision Tutorials 104 

 

Step 10 

We can now add the regional magnetic field and forward model response for all flight lines to 
the existing map display. Earlier we activated all the synthetic flight lines for modelling, so 
press the compute button to make sure the model response and regional are up to date and 
then add the regional field (MAG_REGIONAL) and magnetic model field (MAG_MOD) to the 
map view. Change the colour of the regional to black and the model field to blue.  Also, turn 
of the Contour, Flight Lines and Base Lines layers to decrease clutter. 

 

Step 11 

We will start the inversion process for the single body in Line L04 before moving on to full 
map inversion.  This helps us become comfortable with the depth, properties and position of 
the basement target. First select the section for Line 4 and then open the inversion toolbar 
Tools>Inversion menu item or right click in the background workspace. This will display the 
Inversion toolbar which contains the controls for the inversion. 

Select the Free button which opens the Free Parameters dialog.  In the cross section view 
select the active body to make sure that it appears in the Select bodies field in the Free 
Parameters dialog. All bodies are selected by default and if you start inversion on the single 
line when all bodies are selected, the behaviour of the individual bodies that are not near the 
line will behave poorly during inversion.  We will address the other bodies during full map 
inversion. 
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Next set the Distance, Z body (depth), Dip, Thickness and Reg level free.  If you see X, Y 
parameters instead of Distance, then you must have had the Map Window active when you 
opened the inversion toolbar. Set the data decimation for inversion to 2 in the data control 
dialog accessed from the Data button on the Inversion dialog. Run the inversion and you 
should end up with a result similar to that shown in the figure below. 

 

Note that the regional has shifted down from the regional fix points that were calculated at 
the start.  These can be reset in the regional dialog, but we will do that later in the map 
inversion.  The initial inversion gives a depth of around 150m with a dip to the west.  Local 
deviations from the model on the flanks indicate the existence of shallower magnetic 
sources.  These could be associated with the mineral sands targets that we are trying to 
enhance. 

Step 12 

Now it is time to do a full 3D inversion from the map where we will use the stacked profiles to 
help guide the process.  Make the map window the active window and it should look 
something like the following figure.  Make sure that the contour and image layers are turned 
off. 
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Note that the Mag channel in red does not cover the full extent of the lines because null 
values were assigned where the grid data was null.  This fact is important because there can 
be no null value in the data used by inversion. 

For this reason, we want to select only non-null data points for inversion and also, only the 
data points that are immediately affected by the four active bodies. Ensure that the map 
window is active and then select the Active Points toolbar button.  Select the Deselect All 
button first followed by the Draw map polygon button and then draw a selection polygon 
around the data points in a shape similar to that shown in the next figure.  Make sure there 
are no null data values in the selection. 

 

Step 13 

Set the depth of the small bodies to the north and south to 150m to be consistent with the 
initial inversion results. Adjust the susceptibility if needed. 

Set the data decimation to 5 to keep the number of data points used in the inversion to 
around 500. 

Focus on the second large body under lines 8 and 9 bcause the fit for the body covered by 
line 4 is OK as a starting point. Progressively free up the Property, Azimuth, Z, X and Y, 
Dip and Strike. You can use the Revert button at any stage where you feel the inversion 
has gone in the wrong direction.  You can adjust the Reg. level at the end of this process 
after turning off all the free parameters. 
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Now select both large bodies and free up their Thickness, Azimuth, Z, X and Y, Dip and 
Strike and you should end up with a solution similar to that shown below. 

 

Now disable all free parameters for all bodies and enable the regional level and slope.  Run 
the inversion once and you should see an improvement in the RMS. 

Since the two small bodies have only a minor influence, we can now free up their position, 
depth and, property. Once you have reasonable matches for these, disable their free 
parameters and tidy up the two large bodies by free position, depth, dip, azimuth, strike and 
thickness. You should end up with a solution similar to the figure below. 
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Step 14 

Now that we have a model result for the basement geology, we can move on to look at the 
residual response of shallower magnetic sources.  Note that the model response has only 
been compute within the area of the active points polygon so we must activate all the points 
on all the lines and run the forward model calculation. Use the Active Points dialog and 
choose Select All which will activate all data points.   

Compute the residual difference between the mag field data and MAG_MOD model 
response using the Calculator in Line mode. 

 

In the map window, turn off the stacked profile maps and display the new magres field.  Set 
the vertical scale to 25, the line colour to black.  Turn on shade Above and Below and set 
the base level to zero with colours of Red and Blue respectively. 

  

The colour shaded residual highlights both the positive and negative residual trends. 
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There are small residual difference that result from imperfect modelling, but the knowledge 
that comes from the modelling work can be use to better understand the character of the 
residuals and potentially identify and further model small residual anomalies that could be 
associated with near surface mineral sand deposits.  

You can add back the contour layer to see how the residuals relate to the main trends. 
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Tutorial 9 – Modelling PolyGroup Bodies 

1BAim 

This tutorial will teach you how to use the polygroup to build a complete geological section 
by drawing the model over the tops of a geologist's cross-section. This is the building block 
for modelling regional geological sections, depth converted seismic sections, full mine 
models or complex geology associated with an individual magnetic anomaly. 

 

Intended User Level 

This tool will be used by all levels as it forms an important part of ModelVision's tool set. 
Since the tool produces full geological sections it is also important for those wishing to 
produce reports and publication graphics. 

Topics Covered 

• Loading the session file 

• Checking the project settings 

• Checking the modelling settings 

• Adding a geological section bitmap to a model section 

• Creating your first polygon in the polygroup 

• Attaching additional polygons to the group 

• Assignment of densities 

 

Background Information 

The gravity data used in this exercise is taken from a larger geophysical study of the San 
Nicolas deposit. The San Nicolas volcanogenic massive sulphide deposit was discovered in 
1997 near Zacatecas, Mexico by Teck Corporation. Geophysical and drilling data from the 
deposit have been used previously by Encom for the evaluation of the UBC GRAV3D voxel 
inversion using constraints derived from ModelVision. (Pratt, D & Witherly, K 1993, 
“Integration of polyhedral and voxel-based inversion strategies”, GAC-MAC SEG May, 2003, 
Vancouver, extended abstract 4 pp.) 

4BTutorial Data 

This tutorial is designed to demonstrate the method for building complex cross-sections 
using a bitmap backdrop. A session file TUTORIAL 9 SAN NICOLAS POLYGROUP.SES is 
provided with the appropriate settings for the regional, model channels and project 
properties. 
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5BTutorial Steps 

The tutorial will take you through the process of loading a geological section as a bitmap and 
then work through the steps required to populate the complete geological section. 

Loading the session file 

6BStep 1 

Load the session file from \PROGRAM FILES\ENCOM\MVIS 14.0\TUTORIAL\TUTE 
9\TUTORIAL 9\TUTORIAL 9 SAN NICOLAS POLYGROUP.SES. 

You should see a cross-section view for line D6. The curves show the gravity, regional 
gravity and terrain. 

 
Cross section for line D6 

Check the data channels using the menu function Utility>Statistics>Line Data. A gravity 
data channel (gravity) and gravity regional channel (GRAV_REGIONAL) have already been 
loaded. A 3rd order polynomial has been computed from all available lines in the dataset. 

 
Statistical information for the San Nicolas gravity data 

7BChecking the Project Settings 

6BStep 2 

Access the setup dialog from the File>Setup menu and check that the colour palette for 
Bodies is set to San Nicolas. This activates a colour lookup table that matches the colours 
and formation names associated with the geological section used in this tutorial. 
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Setup dialog showing the San Nicolas colour palette 

Note If the San Nicolas Tutorial lookup table is not listed in the Use Palette drop down 
list of this dialog then this file will need to be copied into the appropriate folder 
using the following instructions: 

 
Navigate to .\PROGRAM FILES\ENCOM\MVIS 11.0\TUTORIAL\TUTE9 and copy the 
SAN NICOLAS TUTE.LUT file to .\PROGRAM FILES\ENCOM\MVIS\LUT folder. 

Note The snap tolerance shown in the above dialog is set to 4 pixels. ModelVision 
applies a proximity test to see if you are near an existing vertex on another body 
and if it finds one, ModelVision will automatically attach to the detected polygon. 

 

Checking the Modelling Settings 

6BStep 3 

Check the line modelling settings from the menu Model>Line Control to ensure that all 
channels are appropriately selected as shown in the dialog below. 

 
Line Control dialog for the polygroup tutorial session 
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9BAdding a Geological Section Bitmap to a Model Section 

This tutorial uses a geocoded bitmap as a backdrop to guide the construction of a polygroup 
model. This is not necessary for creation of polygroup models, but it is a useful illustration to 
show how you can create complex models from control information. 

You can attach the geological section bitmap from the cross-section dialog. Select the Layer 
Table button in the main toolbar to display the Cross Section Layers table and click on any 
of the layers with the right mouse button to select the Add>BMP File option from the pop-up 
menu that appears. 

 

Use the file chooser to locate the BMP file in \PROGRAM FILES\ENCOM\MVIS 
11.0\TUTORIAL\POLYGROUP\SECTION 400S CLIPPED BMP.BMP. 

You will then need to enter the x,y,z coordinates for the image corners. 

 
Dialog for geocoding of the geological section bitmap 

You should now see the geological section appear in the lower section. 

 
Cross-section view with georeferenced bitmap of the geological cross-section 
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10BColour Coded Lithology Table 

A colour lookup table called San Nicolas Tute was created specifically to mimic the colours 
in the geological section. Each colour is assigned a formation name. 

 
San Nicolas Tute colour lookup table in the LUT Editor 

This look-up table file is provided for you in the \TUTORIAL\TUTE9 folder. 

11BCreating your first Polygon in the Polygroup 

The first polygon in a polygroup is a standard isolated polygon and you will later attach new 
polygons to start construction of the section. The figure below illustrates the first set of steps 
required to create the polygon. 

 
Steps required to create the first polygon in the cross-section 

Select the toolbar button Create Body (1) to open the dialog, select Polygon (2) then select 
the colour square to access the colour/lithology selector (3). Choose the red colour for the 
Massive sulphide (4) and this lithology will be assigned to the polygon that you draw. 

3 

 

4 

 

5 

 6 

 

2 

 

 

1 
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Alternatively, Step 4 can be replaced by selecting from the pull-down list by the name of the 
formation. Next enter the density (5) and strike length (6) for the polygon. Note that each 
subsequent polygon in the polygroup will have the same strike length. Also, if you change 
the strike length of any polygon, all will be changed at the same time. 

Trace the path of the red area (Massive sulphide) and close the polygon by selecting the 
point where you started. The figure below shows the shape of the polygon with each point 
highlighted. This is achieved by selecting the Body Edit mode toolbar button and then the 
polygon. 

 
A polygon is drawn around the Massive sulphide formation outline 

12BAttaching additional Polygons to the Group 

A polygroup is formed by attaching a new polygon to an existing polygon. Two or more 
connected polygons are required to form a polygroup. Individual polygons within the group 
can be selected, edited, detached and deleted. 

The polygroup has many of the advantages of individual polygons, but share the attributes of 
strike length, group position and group azimuth. If you change any of these parameters on a 
single polygon, the polygroup will change. 

We recommend that you don't change the azimuth as this may make it difficult to append 
additional polygons as the polygroup is nominally attached to a line of section. 

The process begins by starting the new polygon at a point that is not on the connecting 
polygon. That is, you will start drawing at a point beyond the first polygon and then later 
connect to the target polygon. Although starting from a point on the polygon may 
work, it is not recommended as the attachment is not always reliable. 

Select the lithology style called "Sulphide" which has a pink colour and start drawing from the 
upper left extremity of the zone as shown in the figure below. Trace the upper margin until 
you connect with the first polygon. You must hear an audible "click" from the computer to 
know that the point is properly selected. If you don't hear the sound, then move back and 
over the target vertex until you hear the click. 
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Trace the top of the Sulphide zone (pink) until connecting to the first polygon where an audible click will be heard 

Now that you have "connected", ModelVision knows that you are building a polygroup as 
opposed to a single polygon. If you accidentally connect to the wrong point, you can undo 
the point with a right mouse click and connect somewhere else. You can always disconnect 
an individual polygon from the group via the property page for the body. 

Instead of clicking on each point in the joined polygon, you can shortcut the process by 
connecting to a distant point along the edge as shown in the next figure. 

Once selected, ModelVision autotraces the edge of the polygon to the selected point. 

 
Shortcut selection across the connecting polygon 

 
ModelVision completes the job by auto-tracking around the connecting polygon to the selected vertex 
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You can now complete the drawing of the "Sulphide" zone by tracing the pink zone back to 
the starting point as shown below. The "Sulphide" zone is filled with the pink colour and the 
outer border of the two polygons is traced by a thick blue line to define the outer limits of the 
polygroup. 

 
Completion of the Sulphide zone and blue outline of the polygroup 

You can complete the whole geological section in a few moments as shown below.  

 
Partially completed and extended polygroup section 

The uppermost formation has been left out to illustrate the shape of the polygroup.  

Note The outer formations have been extended laterally to avoid sharp edge effects 
from the arbitrary termination of the section at the end of the geological section. 

 
You can check the shape of the section in the 3D perspective view as it is updated 
automatically as the model is drawn. 
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3D perspective view of the polygroup model 

13BAssignment of Densities 

You can assign the densities as you create each polygon or edit them in the body table as 
seen in the figure below. 

 
Body parameter table for the completed polygroup body 

The Body Parameter table lists the group that each polygon belongs to and in the above 
table, they are all set to 1. 

Note Some formation names have a number following them to indicate a subsequent 
occurrence of the same formation, while providing a unique name for each 
polygon. 

 
You can now experiment with inversion of the polygroup by allowing some of the densities to 
vary. The densities will change to get the best match with the gravity along the section. If you 
are confident in the assignment of densities, then you can use the residual gravity response 
to look for unexplained components of the geological section, particularly additional massive 
sulphides. 

Note The process can be repeated on adjacent cross-sections to build full 3D models 
of the sub-surface. The sections must be parallel and touch exactly midway 
between the sections. 
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Tutorial 10 – Integrity Check of Imported Models 

1BAim 

This tutorial will teach you how to use the Topology Checker plugin tool to check the integrity 
of models imported from 3D DXF files and other file formats.   

 

Intended User Level 

This tool will be used by all levels as it forms an important part of ModelVision's tool set. 
Since the tool produces full geological sections it is also important for those wishing to 
produce reports and publication graphics. 

3BTopics Covered 

• Loading the session file 

• Checking the project settings 

• Checking the modelling settings 

• Importing a 3D DXF of a simple model 

• Checking the vertices of model faces using the Topology Checker 

• Exporting the corrected model as a .TKM file 

Background Information 

Previously it was essential that the software which created a DXF file used a consistent 
method of ordering the vertices of every face and that all surfaces were closed. This is a 
requirement of ModelVision and any gaps or incorrectly defined faces in a model will lead to 
errors in the model computations.  

The topology checker collates all faces and organizes them into closed surfaces reporting 
any that break the rules. If the problem is with badly ordered faces then it corrects these 
automatically and allows the user to export the intact surfaces as a new DXF file or as 
individual polyhedron bodies in a TKM file that will be automatically loaded into ModelVision.  

If there are holes in the surface of the body then it does not fix them for you. It will allow you 
to export the valid closed bodies and reject the invalid ones. It gives the user the means of 
tracking down the problem in the surface but the user must relate this back to his DXF file 
and fix it. The fix should involve going back to the program which wrote the DXF file rather 
than correcting the file. 

The topology checker has its own 3D visualizer with many features to identify and examine 
anything from the entire model right down to individual facets and their coordinates. 
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Tutorial Data 

This tutorial is designed to demonstrate the method for using the Topology Checker to 
determine the integrity of an imported 3D DXF model. A session file called TUTORIAL 
10_TOPOLOGYCHECKER.SES is provided with the appropriate settings for the regional, 
model channels and project properties. 

Tutorial Steps 

The tutorial will take you through the process of importing a tabular model as a 3D DXF and 
using the Topology Checker utility to check the model for badly ordered faces or holes in the 
surfaces.  

Step 1 

Load the project file from .\PROGRAM FILES\ENCOM\MVIS 11.0\TUTORIAL\TUTE 10. 

The modelling parameters should be similar to below: 

 

Load the session file from the same project folder, called:  

Tutorial 10_TopologyChecker.ses 

You should see a 2D grid image map display, showing the magnetics of the dataset. 
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Step 2 

The Topology Checker utility can be accessed from two menu locations in ModelVision. The 
most obvious place to access this and to import a model is the Model>Import menu option. 
Selecting any of the file formats excluding the native ModelVision format (.TKM file) 
displayed in this menu option will activate the Topology Checker.  

 

The other location to initiate the Topology Checker is the Model>Body Operations menu 
option. 
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Initiate the Topology Checker using one of these two menu options and browse for the x-
section_error.dxf file located in .\PROGRAM FILES\ENCOM\MVIS 
11.0\TUTORIAL\TUTE10 folder. 

 

The Topology Checker interface will display with the model DXF file loaded as illustrated 
below: 

Step 3 

The Topology Checker interface consists of three display areas: 

1. 3D View 

2. Input File and List View 

3. Surface and Rendering Properties 
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The first and most obvious is the 3D display window where the imported model is displayed 
in an area where 3D navigation is possible. Similar to the Perspective view in ModelVision 
the left and right mouse buttons allow navigation in the space. The left mouse button 
activates the horizontal and vertical rotation of the model and the right mouse button 
activates the zoom in/zoom out action of the model. 

Experiment with the 3D navigation using the left and right mouse buttons to view the model 
at different orientations. 

Step 4 

The toolbar beneath the 3D display allows some simple properties of the 3D view to be 
edited.  

  

 

The Fit view to window button adjusts the view so that the entire model can be 
seen. Select this button to reset the view for all bodies in the model. 

 
The Fit view to bounding box of selected surface button fits the view so that the 
selected surface is the focus of the view. Select this button to reset the 3D view 
to focus on the selected surface from the List View. 

 
The advanced settings for the axes scale button  allows the user to apply 
individual scales to the X, Y and Z axes, as well as defining the position where 
the user wants the view to look at. Experiment with this setting by adjusting the 
Look towards angles and Scaling options. Click on OK after each adjustment to 
observe the change in the 3D view. 



 ModelVision Tutorials 124 

 

 

The Zoom Speed button changes the speed at which the user can zoom in/out to/from the 
model. This improves the handling of the model in 3D. Adjust the slide bar for this option and 
observe the changes in the zoom speed while navigating around in the 3D View. 

The Background Colour button  sets the colour of the background window 
for the 3D view. Depending on the colours used in the model being displayed you may wish 
to adjust this to Black for improved visualisation.  

 

Step 5 

 
The Input File button selects the model file to load into the Topology Checker. To 
open the Topology Checker a file has to already be chosen but once opened 
another file can be opened using this button. 

The List view with a (scroll bar option) displays all surfaces for the input model and their 
corresponding properties. Use the button on the right of the mouse to select the List View 
column headers to activate a context menu with various options on how to sort and select 
cells (i.e. ascending or descending). 

 

A definition of the List View Columns is as follows: 
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Layer The name of the layer in the input file of one is provided. 

Surface The surface number 

Show Select/Unselect the tick box to show/hide the surface 

# Faces The number of faces in the mesh for the surface 

Area The area of the surface 

Volume The voume of the surface 

Closed Green tick indicates that the surface is closed. A surface 
is closed if all edges of the triangles in the surfaces mesh 
are shared by another triangle in the mesh. 

 Blue tick indicates the surface is closed but has a 
negative volume.  

 Red cross indicates that the surface is not closed.  

# Unclosed Edges The number of edges that are not shared in the surface. 

Export Indicates whether the mesh for this surface should be 
added into the output file when saving. 

 
Examine the list of model surfaces for the displayed model in the spreadsheet view of the 
Topology Checker.  

   
You will notice that the last layer of the imported model has a red cross assigned 
to the closed column and that the Export box has been deselected.  

It is obvious while rotating around in the 3D view that the smaller polygon body has an 
unclosed edge on it.  

Step 6 

 

The Properties button displays a spreadsheet containing the X,Y, and Z coordinate for each 
vertex in each triangle for the surface selected in the List View. Triangles that are not closed, 
i.e. have an edge that does not join another triangle are displayed in a different colour. 

Select the Properties button to open the “Surface Properties” dialog for the currently 
selected surface in the list view.  
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11BStep 7 

In the Global options the Define each layer in a separate mesh check box will determine 
whether a defined layer in the input file should be defined in its own mesh or whether all 
layers should be defined in a single mesh. This is done on loading the input file. 

 

The Coincident Point Tolerance value displayed is used to improve the mesh by detecting 
coincident points and reassigning the triangles to use the first instance of any repeated point. 
Set this to -1 for the Topology Checker to automatically calculate this value. 

Selecting the Advanced… button will open the “Advanced Options” dialog. This dialog 
allows the user to specify the ‘Body Density’ and ‘Body Susceptibility’ values for the model. 
These are used when saving the model to a .TKM file. 

 

Set the Body Density to 2.77g/cc and the Body Susceptibility to 0.001 cgs. 

12BStep 8 

 

In the Rendering options the Cull reverse facing check box will turn on/off the display of any 
back facing triangles.  

Toggle this option off and on again to observe this feature. 

The Wireframe check box will turn on/off the display of the wireframe mesh for the model. 
The colour of the wireframe mesh can be chosen by using the appropriate ‘Set…’ button.  

Turn this option on and set the colour of the wireframe mesh to Black. 

Ensure that the Show Unclosed check box is turned on and select the Set button located 
next to it to yellow. When selected the Show Unclosed check box will override the colour of 
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any triangle faces that are not closed in the model with the colour specified in the ‘Set…’ 
button.  

Then turn off the Show check box in the spreadsheet view for the first two surfaces to 
visually inspect this layer in its entirety. A break in the surface has rendered an edge of the 
triangle in the mesh surface to not be shared by another triangle in the mesh and hence 
these are recognised as two separate surfaces with a computed area but no volume. 

 

Step 9 

The Show Selection Bounding Box check box will turn on/off the bounding box for the 
model surface. The red coloured bounding box is defined for the currently selected surface in 
the list view.  

Select the problematic surface in the List View and then if not already done so, turn on the 
Show Unclosed check box from the Rendering options section of the dialog. Turn on the 
Show Selection Bounding Box check box and you will notice a red box displays around 
the surface highlighted in the List View.  

 

 

Step 10 

The Show Selection Normals check box will turn on/off the display of normals for the 
model. The normals are defined for the currently selected surface in the list view only. The 
size of the normals can be modified using the ‘size’ slider control.  Show Selection Normals 
check box and select the first problem volcanic breccia layer.   
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Note A normal is a line perpendicular to another. In this sense it is a direction or 
line perpendicular to a surface (a face or facet on the body).  

Normals are important for two reasons both related to the direction of the 
normal which can be either into or out of the body. The direction is 
determined by the ordering of the vertices and ModelVision requires each 
face to have clockwise ordering when looking into the body from outside. 

1. In the display the direction of the normal determines whether it is an 
outside or an inside face and it may be displayed differently or not at 
all. In ModelVision for instance back faces are not displayed.  

2. The computation of the magnetic or gravity response is done for each 
face on a polyhedral body and the sign will be reversed if you change 
the direction of the vertices and hence the surface normal. Unless all 
faces are ordered consistently the response will be wrong. 

The display of the normals is useful in seeing incorrectly ordered faces. 

 
13BStep 11 

The Transparency check box will turn on/off transparency for the model. The degree of 
transparency can be modified using the appropriate slider control. 

 

Adjust the Transparency slide bar to 30% and observe the changes in the model’s 
appearance. 

 

14BStep 12 

Finally select the Save button and save the imported model in the project folder as a TKM 
file called TUTE10.TKM.  
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A report window will appear providing a summary of the imported model changes made 
while using the Topology Checker. This can be saved as a .TXT file for future inspection. 

 

Select the Close button and the report dialog will disappear to reveal the map window 
showing the imported bodies.  
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Tutorial 11 – 2D Model Generator 

Aim 

This tutorial will teach you how to use the 3D Model Generator to create a closed 3D solid 
body with geophysical attributes from an imported vector file or digitized polygon extruded 
between a top and bottom surface. 

 

Intended User Level 

This tool will be used by advanced modellers and those wishing to extend their use of 
ModelVision by using the UBC Mesh Creator module. Since the tool produces fully closed 
3D geological models it is also important for those wishing to produce reports and publication 
graphics. 

Topics Covered 

• Loading the session file 

• Checking the project settings 

• Assigning surfaces to 3D Model Generator 

• Drawing a polygonal boundary on an elevation surface  

• Importing a GIS vector file containing geological polygons 

• Generating a 3D body  

• Displaying the 3D model in Perspective view 
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Background Information 

ModelVision will allow you to build complex 3D geological models from hand drawn polygons 
or imported GIS vector files using the 3D Model Generator and Extrusion Wizard.  With this 
tool you can convert a two dimensional map polygonal interpretation into a meaningful three 
dimensional model with associated properties of elevation, volume, density and 
susceptibility.   

High resolution terrain surfaces are compressed using a triangle reduction method 
developed by Encom that is designed to preserve the resolution of the terrain and reduce the 
numerical computation time for the models.  This is an excellent tool for computation of 
terrain corrections. 

Use the 3D Model Generator to create a ModelVision model from a freehand drawn polygon 
or an imported geological map in the form of a vector file (such as .SHP, or .TAB file format) 
containing polygons with attributes assigned to density and susceptibility.  The polygons are 
then extruded vertically between two surfaces (typically an elevation surface and basement 
or base of weathering surface) to produce a closed 3D solid body. 

The Extrusion Wizard allows you to refine your 3D model by applying other properties such 
as body name, colouring, azimuth and dip for the 3D body.  

These models can be applied to problems such as terrain corrections in airborne gravity 
gradiometry, synthetic survey simulation in a known terrain, waste dump modelling in 
engineering geophysics, salt diapir modelling for petroleum or seeding of a UBC voxel 
inversion model.  

Tutorial Data 

This tutorial is designed to demonstrate the various methods for using the 3D Solid 
Generator and the related Extrusion Wizard plug-in tool to produce a 3D body with modelling 
properties such as density and susceptibility. A session file called Tutorial 
11_3DModelGenerator.ses is provided with the appropriate settings for the grid surfaces, 
geological setting and project properties. 

Tutorial Steps 

The tutorial will take you through the process of importing a GIS vector file and drawing a 
polygonal boundary to create a 3D model using the 3D Model Generator and then using the 
advanced properties of the Extrusion Wizard plug-in. 
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Step 1 

Load the project file from .\PROGRAM FILES\ENCOM\MVIS 11.0\TUTORIAL\TUTE 11. 

The coordinate and modelling parameters should be similar to below: 

 

Load the session file from the same project folder, called TUTORIAL 
11_3DMODELGENERATOR.SES. 

You should see two map windows displaying an elevation (DTM) grid in one window and a 
corresponding RTP magnetics grid in the other.  

 

In a Perspective view you will also see a 3D Grid surface of the DTM data vertically scaled 
by a factor of 2.  
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Creating a 3D Model by drawing a boundary on a grid image 

Step 2 

 
The 3D Model Generator can be accessed from the toolbar of ModelVision. When 
this button is selected the 3D Model Generator dialog appears similar to that below: 

 

Ensure that the Boundary & Parameters option to Create from map is selected and enter a 
Body name of Intrusive 1. Also set a Susceptibility of 0.001 and Density of 2.77. Click on 
the coloured box and change the colour to Pink. 

For the Top Surface specify an Elevation grid and select the loaded DTM grid surface from 
the drop down list. For the Bottom Surface specify a Fixed height of -1000m.  

Step 3 

Highlight the map window containing the RTP grid image and then select the Draw 
Boundary button on the 3D Model Generator.  

 

Move the cursor into the map window and the cursor will change appearance to a cross-hair. 
Draw a polygon by using either free hand (by clicking and holding down the left mouse 
button) or specifying vertex locations of the polygon around the magnetic anomaly as 
illustrated below. To close the polygon double left mouse click or create the last node in the 
same position as where you began the polygon. 

  

Once the outline has been drawn on the map select the Create Body button and the 3D 
model will appear in the map window as well as the Perspective view. 
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Creating a 3D Model by drawing a boundary on a BMP Backdrop image 

Step 4 

Return to the map window containing the RTP grid image and select the Layer Table button 
in the main toolbar to display the Map Layers table. In the Project folder select the 
NT_GEOLOGY.BMP file and open this.  

 

The BMP Image Location dialog will appear next. If the image has already been geo-located 
(e.g. from a .EGB file) the X and Y coordinates will be automatically loaded into this dialog. If 
the image is independent of any geo-location you will need to enter the X and Y minimum 
and maximum values into this dialog manually.  

A .EGB file exists for this bitmap image so the coordinates will appear in the dialog 
automatically. Click OK to exit from this dialog and return to the Map Configuration dialog 
where you will also need to click OK.   
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Step 5 

ModelVision has a specific drawing order for most display options and in this case a grid 
image will always taken precedence over a bitmap backdrop image. Therefore the map 
window will still contain the RTP grid overlaying the bitmap image. To change this order click 
on any layer in the Map Layers table with the right mouse button and select the 
Window>Drawing Order pop-up menu option. 

 

The list displayed in this dialog shows a hierarchy for drawing in the map window. Scroll 
down to the bottom of the list to find the BMP file object and highlight it. Select the Up button 
to move this object so that is sits above the Grid Image object type. Select the Done button 
to exit the Drawing Order dialog and to return to the map window.  

A geology map bitmap image of the project area will be displayed over the top of the RTP 
grid image.  
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Step 6 

We can now use this image as a reference for drawing a polygon representing a geological 
boundary in the 3D Model Generator. Zoom in to the map window to view closer the two 
smaller pink polygons (representing granite intrusions) then select the 3D Model Generator 
button on the toolbar to display the dialog. 

 

For the Boundary and Parameters option select the Create from map option and enter a 
Body name of Intrusive 2. Specify a Susceptibility value of 0.0015, a Density value of 2.75 
and Colour of Pink.  

For the Top Surface specify the Elevation grid to be represented by the DTM grid and set 
the Bottom Surface to be at a Fixed height of -1000m.  

Select the Draw Boundary button and digitise around the more easterly intrusion as 
illustrated below. Once completed select the Create Body button and Close the 3D Model 
Generator dialog to observe the new body displayed in the Map and Perspective views.  

  

 

 

 

Creating a 3D Model from a Drawn Boundary using the Extrusion Wizard 

Step 7 

To assign additional properties to the created 3D model the Extrusion Wizard lug-in utility 
can be accessed from the 3D Model Generator dialog after initially drawing a polygon from a 
map view.  

First of all centre the zoomed in geology map image on the granite intrusion (pink) polygon 
located south-west of the previously digitised polygon. 
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Open the 3D Model Generator dialog and specify the Create from map option for creating 
the Boundary & Parameters of the model. Enter a Body name of Intrusive 3, Susceptibility 
value of 0.0015, Density of 2.79 and a Colour of Pink. 

This time leave the Top and Bottom Surface properties as the default values (i.e. Fixed 
height of 0 and -1000).  

 

Select the Draw Boundary button and digitise around the centred granite intrusion as 
illustrated below.  

 

Step 8 

Once completed instead of creating a 3D model from this dialog select the Wizard button to 
open the Extrusion Wizard plug-in dialog. The first dialog of the wizard will appear similar to 
below showing the input file source of the polygon digitised on to the map window, a .TAB 
file called MV_TMP. Select the Next button to move to Step 2 of the wizard. 

 

The Step 2 dialog displays the Set primary surface properties as was shown in the 3D 
Model Generator dialog for the Top Surface. Set the Primary Z value as 0 and click on the 
Plus grid value and browse to the Project folder for TUTE11 to select the MV_DTM.ERS grid 
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file. The Z range of the loaded grid will be displayed beneath this entry. Click Next to 
proceed to Step 3.    

 

The Step 3 dialog displays the Set extruded surface properties as was shown in the 3D 
Model Generator dialog for the Bottom Surface. The Primary Z box has -1000 entered as 
was the value specified in the 3D Model Generator dialog. Click Next to proceed to Step 4.  

 

The Step 4 dialog of the Wizard allows the user to specify an Azimuth and Dip of the 3D 
model created. Select the box for Specify an azimuth and dip to place a tick here and in 
the Azimuth properties select the Use fixed azimuth option and enter a value of 135 
degrees. In the Dip/Tilt properties select the Use fixed dip/tilt option and enter a value of 
80 degrees. Click the Next button to proceed to Step 5.     

 

The Step 5 dialog allows you to Choose body properties to be assigned, consisting of 
Body name, Density and Susceptibility. In this case the properties are taken from the 
Boundary & Properties section of the 3D Model Generator dialog. When importing an 
existing GIS vector file (which we will do in the next exercise) data fields from the vector file 
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can be assigned to these input fields. Leave these fields as the default setting and click Next 
button to proceed to Step 6. 

 

The Step 6 dialog allows you to specify the colour appearance of the 3D model to be 
generated. The default option of From input will colour the model with the colour that was 
specified in the 3D Model Generator dialog, i.e. Pink or in the case or an existing vector file 
that was imported the colour assigned in the vector file. The next option called Fixed allows 
you to override the input colour with a specific colour from the drop down list. The 
Modulated by field colour option allows the model to be colour modulated by a specific field 
from the input file, such a susceptibility using a specified Colour table from the drop down 
list.   

For this exercise select the From input colour option and click the Next button to proceed to 
Step 7. 

 

The Step 7 dialog for the Extrusion Wizard is to Choose an output file (.TKM) for the 3D 
model. Select the browse button to specify the output file location and name and in the 
project folder for TUTE11 call the file INTRUSIVE3.TKM. Select the Save button to return to 
the Step 7 dialog. 
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Note A DXF file format can also be specified here but if this format is chosen the model 
will not be automatically displayed in ModelVision and will need to be imported 
using the Model>Import>DXF format menu option. 

 
The option to Generate a report on the volume of output bodies exists for producing a 
.TXT file containing the calculated dimensions of the 3D model. An example of this is 
illustrated below. 

 

Select this option and click on the Finish button to complete the 3D Model generation using 
the Extrusion Wizard. A message will appear similar to the one illustrated below.  

 

Click OK and a new message will appear asking to Append or Overwrite the currently 
displayed models from the previous exercises. Select Append and the new 3D model of a 
dipping body will be displayed in the map and perspective view windows. 
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Save the current models in a new session by using the File>Save As menu option and call it 
TUTORIAL11_3DMODELGENERATOR_A.SES. 

Exit from this session by selecting the File>Close menu option. 

Creating a 3D Model from a Vector File using the Extrusion Wizard 

When working with a series of complex polygons as found in a geology map, rather than 
drawing a boundary around each rock unit one at a time as instructed in the previous 
exercises it is more beneficial to import an existing GIS vector file containing these polygons 
and already assigned geophysical properties.  

Step 9 

From the same TUTE11 project folder open the original session file called 
TUTORIAL11_3DMODELGENERATOR.SES. 

Open the 3D Model Generator tool from the ModelVision toolbar button and for Boundary & 
Parameters select the From existing file option. Select the Browse button for this option 
and navigate to the TUTE11 project folder and load the vector file called NT_GEOLOGY.TAB.  

For the Top Surface specify an Elevation grid of the loaded DTM grid file and for the Bottom 
Surface specify a Fixed height of -1000m. 

 

Step 10 

Select the Wizard button to execute the Extrusion Wizard plug-in utility. A boundary is not 
required to be drawn in this exercise because the polygons contained within the loaded 
vector file provide the boundaries instead.  

Navigate through Steps 1-4 of the Extrusion Wizard and accepting the default parameters 
assigned by the 3D Model Generator for each of these steps until you reach Step 5 – 
Choose body properties. In this dialog the properties for the bodies to be created are 
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supplied by the fields within the input vector file. The Wizard has automatically detected the 
Density and Susceptibility fields but the Body Name field needs to be manually assigned.   

 

Select the down arrow of the drop-down list for Body name and select the field called 
Map_Symbol that is connected to the vector file.  

Proceed to Step 6 – Set appearance by selecting the Next button and leave the default 
Colour option of From input. Click the Next button to proceed to Step 7 – Choose output 
file and check that the file destination is for the project folder and that the name of the output 
TKM file is called NT_GEOLOGY.TKM.  

Select the Finish button to exist from the Extrusion Wizard and select OK on the message 
window that appears notifying you of the successful creation of the TKM file.  

A 3D model of the entire geology map of the project area is added to the map window with 
colour modulations matching that of the input rock units. 

 

Step 11 

Select the View>Perspective menu option to display the model in 3D.   
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Step 12 

Finally view a list of the bodies for this model by selecting the Body Table button on the 
toolbar. The body name for each polygon extruded will be displayed in the Label column and 
the Susceptibility, Density and Depth values will vary according to the input data from the 
vector file and the DTM grid file.  
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Tutorial 12 – Joint Inversion 

Aim 

The aim of this tutorial is to demonstrate the use of joint inversion on conventional cross-
wing total field gradiometer survey data.  The technique is easily extended to other data such 
as full tensor gravity gradiometry and full tensor squid magnetometers. 

Intended User Level 

Experienced users. Advanced options for inversion. 

Topics Covered 

• Data import 

• Data visualisation 

• Calculation of x,y horizontal gradients 

• Modelling setup 

• Select data for joint inversion 

• Build a starting dyke model 

• Run a 3D Joint Inversion on a single line data segment 

Background Information 

This survey was flown with a helicopter horizontal gradient system with a ground clearance 
of 20m to 25m.  The area has shallow dipping dykes that can impact upon mining operations 
at depth and we need to estimate the dip of the dyke with as much precision as possible 
from a single line of data.  The dykes are believed to be normally magnetized. 

The survey data contains levelled cross-wing (lateral) gradient (dTdc) and total field (TMI) 
data, radar altimeter(RadAlt), absolute flying elevation (Zgps) and ground elevation (DTM). 

Tutorial Data 

The flight line data is stored in the file TUTE12 GRADIENT DATA.GDB and an ER Mapper 
format grid of the total magnetic intensity is called TUTE 12 TMI.ERS.   

Tutorial Steps 

The following steps should be undertaken for this tutorial: 

Step 1: Data import 

Initially, a project is required to define the various properties of the data. ModelVision uses 
projects to manage various analysis exercises and a MVPROJ.INI records your entries for 
later use. Binary session files (.SES) can also be used to store data, models and displays if 
required. 

Select the File>New>Project option and enter the information as required. For this area 
select local datum 

Note that the entries for the Earth’s magnetic field are set to be: 
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Field Intensity :  29132 
Inclination:  -62 degrees 
Declination:  -15 degrees 

Load the ER Mapper format grid (TUTE 12 TMI.ERS) using the File>Import>Grid>ER 
Mapper option (or the CROSS-WING GRADIOMETER TUTE 12 START.SES session file if 
operating ModelVision in Demonstration mode).  

Load the flight line data from the Geosoft database file (TUTE12 GRADIENT DATA.GDB) 
using the File>Import>Profiles>Geosoft(.GDB) option. 

Step 2: Data Visualisation 

Display the TMI grid and flight lines using the View>Map option. 

The dyke that we will model is associated with the dominant linear magnetic anomaly 
trending in a north-north-east sense. 

 

To preview the line data using the multi-track display, use the View>Multi-Track option, 
select line L353 and the TMI, dTdc (cross-wing gradient), RadAlt (radar altimeter), Zgps 
(magnetic sensor elevation) and DTM (ground elevation below sensor position).  Make sure 
that you allow for 5 tracks so that each data channel has a separate track in the display. 
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The multi-track display will appear as shown below and note the relationship between the 
total magnetic intensity channel TMI and the cross-wing gradient (dTdc). 

 

Step 3: Calculation of dT/dx, dT/dy Horizontal Gradients 

Before we can use the data for inversion, we need to convert the gradient data into east and 
west gradients (dT/dx and dT/dy), where T is the total magnetic intensity.  Calculation of 
these parameters requires a vector transformation of the cross wing gradient (dTdc) and the 
along line horizontal gradient (dTda).   

The along line gradient is calculated by computing the first horizontal derivative along the 
line using the Filters>FFT filters>Horizontal derivative. 
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You convert the cross-line and along line gradients to east and west gradients through a 
simple vector transformation. 

dT/dx = dT/da Sin(Θ) + dT/dc Sin(Θ) 

 

dT/dy = dT/da Cos(Θ) – dT/dc Sin(Θ) 

 

In this tutorial, dT/da equates to channel dTda and dT/dc to dTdc and “Θ” is the azimuth or 
the survey lines relative to north (58 degrees).  Create a new channel with the line calculator 
by assigning theta = 58 / 57.2958 (radians). 
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Now calculate the east and west horizontal gradients using the formulae below. 

rdTdx=dTda*sin(theta)+dTdc*cos(theta) 

 

rdTdy=dTda*cos(theta)-dTdc*sin(theta) 

 

The “r” prefix is used to distinguish the measured data from the model channel names which 
are automatically assigned to dTdx and dTdy. 

Warning The calculation of the horizontal in line gradient dT/da using the FFT filter assume 
that the lines are all ordered in the same direction.  In this case, the data is 
ordered from west to east.  ModelVision automatically orients the line data 
sequence to the same direction at the time of loading, even when the flight lines 
are stored in the Geosoft database with alternating directions.  Do not attempt to 
use the FFT horizontal gradient filter unless it operates in the same geographic 
direction for each line.  The dT/dc data supplied by the contractor had already 
been aligned in the same sense.  If you are uncertain about the correct 
orientation, then it will be obvious that the model profiles that you create are 
different and guide you in selecting the correct process. 

 
Step 4: Modelling Setup 

In the Model>Line control dialog select model magnetics, select the Input Channel as 
“TMI”.  Select the Components button and activate the dTdx, dTdy and Bm supplementary 
channels and select Bm as the modelled component.  Use Zgps as the sensor elevation 
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channel and ensure the "DTM" channel is specified for the "Display Topography Channel" 
option. 

 

Note that the TMI channel Bm will be used for display only and not inversion. 

 

Open a cross-section window for line L353 using the View>X-section menu option which 
will open a standard view with the TMI data above the cross-section.  Change the aspect 
ratio by making the frame narrower as shown below and this will accommodate space for the 
two horizontal gradient components dTdx and dTdy. 
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Make sure that you have the cross-section window selected.   

From the Tools menu, select the Joint Inversion-Magnetic option and a tall thin dialog will 
appear, showing all available model components.  Select dTdx and dTdy, and select the tick 
box located to the right of the Bm (TMI) component, which will display the DC Offset option. 
Select the TMI channel from the channel list and enter the value 28888.0. This is for display 
purposes only and will not be inverted, therefore once the offset is specified deselect the tick 
box located to the left of the Bm (TMI) component. 
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To display the inversion channels in the section view, select the Set Tracks button after Line 
353 is selected.  This will automatically add two auxiliary tracks and the inversion channels 
above the TMI track.  Both the recorded data and model channels will be added to each 
track.  Since no modelling has yet been performed, the model channels will be set to the 
background value.  In the case of the gradient channels, this is zero and 28888 for the TMI 
channel. Press Close and the Joint Inversion Channel Selection dialog will close and the 
Joint Inversion toolbar will open.  

 

 
Step 5: Select Data for Joint Inversion 

 

In the cross-section view zoom into the area between the dashed lines which contains the 
magnetic anomaly for the dipping dyke. Select the Active Points toolbar button and drag out 
a section of the profile that selects the clean segment of the gradient anomaly.   
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See the example below for setting up your own view. 
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Step 6 Build a Starting Dyke Model 

Set the vertical aspect ratio for the section to 1.0 so that you can see the flight path and 
ground surface clearly separated.  Insert a tabular body into the section as shown below with 
a depth extent of 500 m and thickness of 25 m. The map view clearly shows that the starting 
model azimuth is grossly different from the true direction of the dyke. 
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The initial model is fitted approximately using manual procedures where you can see that 
there is a big mismatch in the dTdy channel.  It is this mismatch that contains the essential 
information that allows joint inversion to detect the rotation of the dyke.  
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Step 7:  Run a 3D Joint Inversion on a Single Data Segment 

Open the Free Parameter dialog from the Inversion toolbar and allow X body, Y body, Z 
body, Dip, Azimuth, Property and Thickness to float.  Note that you cannot set bounds on 
parameters in Joint Inversion, they are either fixed or unbounded. Run the inversion until you 
are happy that no further convergence is possible and you should end up with a result that 
looks similar to that shown below. 

 

Note that there is a slight phase shift in the peak of the TMI model match.  In part this may 
be due to a slight regional tilt or an uncorrected lag in the survey processing. 

If for some reason your results don’t match those shown here, then open the session file 
CROSS-WING GRADIOMETER TUTE 12 FINISH.SES to check correct data channels and 
settings. 



 ModelVision Tutorials 156 

Tutorial 13 – Magnetic Anisotropy 

Aim  

This tutorial is designed to show you how to use magnetic anisotropy measurements in a 
forward modelling exercise and learn how it can impact on the interpretation of dip and 
remanence.  

We note that magnetic anisotropy can only be used in forward modelling and is not available 
as an inversion parameter. 

Intended User Level  

Experienced users. Advanced options for modelling and inversion.  

Topics Covered  

• Computing and initial model with an effective magnetic susceptibility. 

• Inverting on data where anisotropy is present. 

• Entering anisotropic magnetic susceptibility measurements. 

• Visualising the maximum, intermediate and minimum susceptibility axes. 

• Computing the forward model with magnetic anisotropy. 

• Inversion on resultant magnetization. 

• Equivalence of magnetic anisotropy and magnetic remanence. 

Background Information  

The data for this exercise is created from a synthetic model that is designed to simulate a 
linear magnetic horizon similar to a banded iron formation.  The anisotropy measurements 
used in the tutorial are taken from laboratory measurements of a banded iron formation, but 
they are not aligned with the model tabular body. The following table has an example taken 
from a laboratory report that shows the declination, inclination and magnetic susceptibilities 
for the major, intermediate and minimum susceptibility axes. 

Sample # Depth (m) Ellipsoid Axes Dec Inc k x 10-6 
  Max 256 19 35146 
PS631 121.8 Int 148 40 33954 
  Min 5 43 10649 

 
Be careful in drawing any general conclusions with this example as the high amplitude major 
and intermediate axes would generally be aligned with the plane of the formation sheet.  
That is not true for the model used in this example. 

Tutorial Data  

You will use the session file TUTE 13 ANISOTROPY.SES for learning about magnetic 
anisotropy.  Load the session file and you will be presented with a map view of the data and 
model responses along with a central cross section that you will use for the modelling 
process.  
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Starting session for the anisotropy tutorial. 

The original anisotropic magnetic model values are shown in black and the model response 
in red. 

Note that only the central Line 14 is active during the process and this is set to zero for the 
initial run.  The surrounding lines have been pre-computed for the starting model where the 
magnetic susceptibility has been assigned to the equivalent, non-anisotropic value (effective 
susceptibility).  

Tutorial Steps 

Step 1: Enter the Effective Magnetic Susceptibility  

The effective magnetic susceptibility (keff) that would be computed from the following 
relationship: 

keff = |K.F| / |F| 

where, 

K is the anisotropic magnetic susceptibility tensor 

F is the geomagnetic field vector. 

Enter the effective susceptibility value of 0.0318301 into the susceptibility field. 

  
Enter the effective magnetic susceptibility. [image An-2.png] 

Now compute the forward model response and you should see the response as shown 
below.  Note that anisotropy mode has not been turned on at this time.  
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Model response(red) for the effective susceptibility curve and anisotropic total magnetic field response (black) 
computed using the values from the laboratory. 

There is a difference between the two curves that cannot be explained by the same 
geometry.  You can use inversion to try and match the shape by varying the position 
(distance), depth (Z), dip and property, but you will not get an exact match as shown below. 

 
Inversion results for show a close but imperfect match 

A dip of approximately 8 degrees is required to improve the curve match. 

Now it is time to activate the anisotropy computation by selecting the Aniso radio button, 
activate anisotropy with the Anisotropy check box at the bottom of the anisotropy panel and 
enter the values from the laboratory table as shown in the dialog below.  Note that the three 
susceptibility axes are orthogonal and if you make a mistake, the program will flag the 
problem with a pop-up dialog and suggest which axis has a problem.  This is a handy feature 
as it is almost impossible to tell from the numbers that you type that you have made a 
mistake. 
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Enter the magnetic anisotropy tensor values as shown for the major (Axis 1), intermediate (Axis 2) and minor (Axis 
3) axes after checking the Anisotropy checkbox. 

Note also that the magnetic anisotropy for this laboratory measurement is very high at 3.3, 
yet the difference between the models with and without anisotropy is relatively small.  The 
magnitude of the difference will vary with the orientation of the anisotropy axes. 

Use the View button to check the orientation and amplitude relationships of your anisotropy 
tensor.  It can also be used to help diagnose problems with your data entry. 

  
Use the View button to display a 3D view of the anisotropy tensor. 

Click with the left mouse button on the 3D sphere and then click a second time to activate 
the 3D movement.  You can rotate the sphere to any view point to obtain the perspective that 
you need.  Note that the three axes are shown in red, green and blue vectors, north as the 
black vector and zero declination as a grey dot on the equator. 

Now compute the forward model response after you close the property dialog and you 
should see a perfect profile match between the original data (black) and the newly compute 
anisotropy response in red. 
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Model response(red) for the anisotropic magnetic susceptibility model curve and the original total magnetic field 
response (black) computed using the values from the laboratory.  

Anisotropic magnetic susceptibility has a similar effect to magnetic remanence because it 
changes the resultant magnetization direction inside the target.  Thus it is appropriate to look 
at this equivalent effect by using inversion to determine the resultant magnetization direction.  
First turn off the magnetic anisotropy calculation by selecting the Aniso radio button and 
then uncheck the Anisotropy check box at the bottom of the anisotropy panel.  Select the 
NRM radio button and enter a value of 0.1 for the Koenigsberger ratio Q. 

  
Set the Koenigsberger ratio Q to 0.1 prior to inversion. 

Now open the inversion toolbar and set the Target rms to 0.1.  Next select the Free button 
on the toolbar and check the Distance, Z, Dip, Property, Res magn, Res. Inclin, and Res. 
declin boxes: 
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Inversion parameters prior to starting inversion. 

After inversion you should end up with a result as shown below. 

  
Inverted response (red) using resultant magnetization inversion. 

Check the NRM property panel after the inversion and you will see that the resultant 
magnetization vector has an inclination of approximately -51 degrees and declination of 
approximately 1 degree.  This represents a departure of approximately 10 degrees from the 
vector direction of the inducing magnetic field. 

  
The resultant magnetization vector has an inclination that is approximately 11 degrees different to the induced field 
vector direction after inversion. 
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Tutorial 14 – Remanence from Magnetic Moments 

Refer to “Sample Synthetic Dataset” on p. 372 of the ModelVision User Guide. 
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Tutorial 15 – Target Wizard 

Aim 

This tutorial will teach you how to use the Target Wizard to quickly perform multi-line 3D 
modelling and inversion of individual anomalies or anomaly groups. The Target Wizard 
combines many separate processes into a single intelligent workflow that reduces the total 
time by up to 90 percent. 

The figure below shows the basic steps of anomaly data selection, modelling and inversion 
of the data subset and restoration of the new body to the master session. 

 

Intended User Level 

This tool will be used by interpreters that have already learnt how to create models and run 
the inversion tools.  The Target Wizard takes a commonly used workflow for 3D modelling 
and combines all the processes into a semi-automated procedure which allows the 
interpreter to focus on the geological problem. 

Topics Covered 

• Loading the session file 

• Selecting the target anomaly 

• Running the Target Wizard 

• Creating a starting model  

• Running inversion to produce a quality circular pipe solution 

• Use inversion to determine the resultant magnetization vector 

• Restoring the inverted body to the master session. 

Background Information 

The example session file has many magnetic anomalies that are suited to interpretation 
using steeply dipping pipe like bodies or tabular bodies.  The geological objective is to 
estimate quickly the depth of cover, target shape and magnetic properties including resultant 
magnetization departure angles.     
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Tutorial Data 

The data is a subset of a much larger survey near Bourke NSW.  The flight line data includes 
sensor elevation, terrain data and total magnetic intensity.  A session file called TARGET 
WIZARD TUTORIAL 14 INPUT DATA.SES is provided with the line data and magnetic 
grid. 

Tutorial Steps 

The tutorial will take you through the process of loading the session file, selecting the 
anomaly of interest, running the Target Wizard, running forward modelling and inversion 
followed by restoration of the master session file with the new body appended. 

Step 1 Loading the Session File 

Load the project file from ..\TUTORIAL\TUTE 14. 

The settings should be similar to those shown below: 

 

Load the session file called TARGET WIZARD TUTORIAL 14 INPUT DATA.SES. 

You should see a map window containing an image of the magnetic data subset overlain by 
the flight lines.  

 

Now use the Zoom tool to select the area around the two circular magnetic anomalies. 
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Step 2 – Running the Target Wizard 

 

The Target Wizard can be accessed from the toolbar of 
ModelVision. When this button is selected the Target Wizard dialog 
appears. 

 

Now draw a polygon around the anomaly as shown below and give it the name Pipe_1. Note 
that there should be no spaces in the name. 
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Your polygon is defining the area that will be used during inversion, so it is helpful to avoid 
the small anomalies on the southern side. 

Select the Preview button which updates some dialog fields and the map area is highlighted 
with the data that will be used during the Target Wizard session.   

 

This highlighted data will be isolated for calculation of an initial regional surface and the data 
points within the polygon will become active for modelling and inversion. 

The dialog is updated with a minimum line length calculation and the name of the polygon 
that you entered.  In this example, there are less than 20 lines available to open as cross 
sections, so leave the number at 20.  You can delete unwanted sections from the display 
later. 
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The Target Wizard uses an algorithm to optimise the line selection if you choose a number 
less than the available lines.  For example, you may choose 10, but get 8.  The algorithm 
tries to select every 2nd, 3rd or 4th line to maintain an even line spacing.  Note that all the 
highlighted data is used for modelling and inversion even if it is not shown in a cross section. 

A first order regional is a good choice for this anomaly and it is always better to use the 
lowest possible order you can to represent the local regional from interfering sources.  If you 
have multiple overlapping anomalies, then you can use the Target Wizard to model them 
together. 

Select the Apply button and the following will happen: 

• The master session is saved. 
• Crop the project to the bounding rectangle defined by the red lines. 
• Deactivate and hide all existing bodies (none at this time). 
• Open the new sub-session data and selected cross sections. 
• Ask you to compute (the regional). 

 

You need to select the Compute button to produce a regional for all the cross sections.  The 
regional is calculated for the complete data subset rather than the data just within the 
polygon boundary. 

Step 3 – Running Modelling and Inversion 

ModelVision opens the new sub-session with all the selected lines as cross sections and one 
extended map view.  Note that the Target Wizard has applied the menu function View>Tile 
windows (custom) to the available windows.  If your workspace looks different to this, then 
you may have different setting for the custom tiling. Check your settings in View>Tiling 
options. 



 ModelVision Tutorials 168 

 

Now you can Close the Target Wizard and perform your modelling and inversion as you 
would normally within ModelVision. 

All cross sections have been scaled to suit the dynamic range of the individual section, but 
for Wizard modelling that is not ideal.  It is better to have all sections scaled the same.  
Select the window Section L601460 and use the Right Mouse Click to bring up the properties 
menu.  Select Apply Scale to All and all of the cross section windows will be redrawn to that 
scale. 

 

Delete the top four cross sections as there is little useful information in these lines. 
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Then use the View>Tile windows (custom) View followed by rescaling of the sections 
using Apply Scale to All and all the sections will be redrawn. 

 

You are now ready to start the modelling process. Select the map view and then insert a 
circular pipe between the high and low.  Set the default depth to top at 100 metres, depth 
extent to 2000 metres and then compute the model.  Your result will be similar to that shown 
below, but will depend on the radius you selected and x, y body position. 
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The next step is to run inversion on the model by selecting the menu option 
Tools>Inversion – Magnetic.  Depending on the polygon you drew, you will 
have around 5,000 data points active for inversion.  Too many for normal 
operations and you should only need 200 to 500 data points for a single 
anomaly target of this type. 

Select the Data button and set the Compression to 10, which reduces the 
data to 1 in 10 data points. 

Now select the Free button and open up the free parameter dialog.  You can 
leave Free Parameter dialog open during the inversion process. 

 

Select the body in the map view to make sure that the map window is active rather than an 
individual profile and the name of the body will appear in the Free Parameters dialog.  Now 
set X, Y, Z, Property and Reg. Level free. 

Don’t set the regional slope free until later when you are approaching a good match.  Run 
the inversion with these parameters and you should see the RMS reduce below 3%.  You 
will see that the depth of the pipe has also increased. 

Once you cannot get any further improvement, set the Radii to free then do another run with 
the Reg. slope set to free. 

By this time you should have a reasonable match with an RMS between 2% and 3%. 
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Step 4 – Inverting for Resultant Magnetization 

 

At this stage the match is excellent, but the background regional and Line 601470 show 
some residual differences that could be explained by magnetic remanence.  To explore this 
possibility, toggle the NRM/Resultant button to Res. and check all three of the resultant 
magnetisation parameters.  Make sure Property is turned off as this is incompatible with 
inversion for the resultant magnetisation.  You can leave the Reg.slope free although there 
is always a possibility that it will interact with the magnetization vector inclination and 
declination.  You can always control this using the regional handles if necessary. 

You should also set your inversion RMS target to 1.0 as it is likely that the RMS will drop 
below the default setting of 2.0. 

After you run the inversion for remanence, you should have all features of the anomaly and 
the regional well resolved as shown below. 
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Now open up the body properties dialog for the circular pipe and select the NRM tab.  You 
should see the ARRA departure angle (Jres-Jind) around 27 degrees. 

 

Now select the View button to obtain a 3D view of the Induced, Resultant and estimated 
Remanence vectors. 

 

The additional step required to obtain the resultant magnetization vector is easy with the 
Target Wizard and is recommended as part of the routine procedure for interpreting limited 
strike length magnetic anomalies. 
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Step 5 - Returning to the Master Session 

Now that the modelling of the isolated magnetic anomaly is complete it is time to pass the 
new body back to the master session.  Any bodies that were passed into the sub-session 
were deactivated and hidden during the current session unless reactivated.  They will be 
returned to the master session along with the new body.  Note that when you first run this 
tutorial there are no bodies present in the master session, but after your first run the bodies 
will accumulate in the master. 

Select the menu File>Return subsession to master and when asked to save the session 
file click OK and it will overwrite the initial sub-session with the file name TARGET WIZARD 
TUTORIAL 14 INPUT DATA_PIPE_1.SES. ModelVision appends the polygon name to the 
master file session name.  This is useful if you want to open a sub-session later.  You can 
choose not to save the sub-session, but it is recommended that you keep the sub-sessions 
while learning how to use the wizard. 
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After running Target Wizard on the adjacent anomaly, the master session changed as shown 
below with the data sub-set highlighted in red. 
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Tutorial 16 – UBC Module 

This tutorial is designed to provide an overview of using the UBC module MAG3D with 
ModelVision. You will create an artificial but complex body magnetic response and use this 
as the input to the UBC MAG3D module. The voxel result of the inversion should reasonably 
match the initially used target body. 

In a real-world case, you must have observed data plus a reasonable idea of the shape and 
property distribution of the target source. The creation of an appropriate 3D mesh and 
property distribution is shown in the tutorial. 

Note UBC Model Mesh Designer is an ModelVision module and is not automatically available. 
A license message will be displayed if the module has not been licensed. For licensing 
details, please contact Tensor Research Pty Ltd. 

 

Tutorial Data 

For this tutorial you are required to load the ModelVision session file located in the UBC 
software directory as installed from the UBC Installation CD. Refer to UBC-GIF Software 
Installation for instructions on this. The session file is located in the 
C:\PROGRAMDATA\ENCOM\MVIS\TUTORIALS\TUTE16 UBC MODULE folder and is called 
TUTE16 UBC MODULE.SES. 

Running the Tutorial 

Step 1 

Start ModelVision and use the File>Open>Session menu options to browse for and open 
TUTE16 UBC MODULE.SES. When it is loaded a preliminary plunging prism and computed 
response should appear as a map and 3D view similar to below: 

 
Opening display from the TUTE16 UBC MODULE.SES session file 

 

To display the properties of the body, click the Property button. This shows that only a 
single Plunging Prism body is shown in the window. From the Body Parameters table 
double click the ‘1’ at left side and the properties dialog of the body is displayed. Note in 
the display that upper and lower bounds for magnetic susceptibility and density can be 
specified. In this version, the bounds for magnetics are not operational but they can be 
set for density. 
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Dialog with UBC bounds settings available 

Step 2 

With the bounds, model and data displayed and specified, select the Modules>UBC Model 
Mesh Designer menu option. This option displays a dialog as below. Examine the dialogs 
and tabs presented by this option. 

 
Export UBC model dialog with Mesh, Data and Bounds specifications 

The Export UBC Model dialog has tabs for defining the mesh, data and bounds.  

Mesh 
For each of the three orthogonal directions of a mesh (X,Y and Z), you can specify the 
number of cells and their size for the core and padded areas surrounding the core.  

Various controls allow the padding of cells to use a geometric factor for distribution. 

Use the Show mesh in 3D option to display the mesh design in Perspective View in two 
different designs. The default view is Perimeter which will show a bounding box for the core 
area of the UBC model and another bounding box for the padding area.  
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The Plunging Prism model with core and padded area specification 

The other display option from the drop down list is to show All Cells, which when selected 
displays a preview of all cells within the UBC mesh being designed. 

The Perspective View will update in real time when a change is made in the UBC Model–
Mesh Designer dialog. 

 
The Plunging Prism model with a 1.5 geometric weighting applied to the padding 

Data 
The Data dialog allows you to specify the data channels, topography and elevation used for 
the UBC inversion. Ensure that the correct modelling method (magnetics or gravity) is 
selected before modifying the data definitions. 

Each data reading can be used or every nth reading using the Sample interval setting. The 
computed response can be at a flat surface elevation above the model (at a Fixed value of 
elevation) or using a topographic gridded surface. 

Note If you are using a topographic surface, the area of the surface must completely cover the 
core and padded area of the mesh. 

 
 

Output files required can be nominated for saving after the inversion.  
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Data control tab for the UBC modelling 

Boundsl 
The Bounds control tab is used to specify the background cells surrounding the ModelVision 
seed body. The bounds are specified for the properties of the relevant method. 

 
Bounds control tab setting the upper and lower bounds for the UBC modelling 

Step 3 

Using the defaults of the TUTE16 UBC MODULE session file, from the right side of the dialog, 
select the Create button. This operation writes the relevant files into the same directory as 
the initial session and model. As the files are created, ModelVision also reports the number 
of mesh cells, volume and padded area details. 

 
UBC model and mesh report after creating the control and data files for the inversion 
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Step 4 

Click the MeshView button. This executes the UBC 3D viewing software (MeshTools 3D).  

 
MeshTools 3D view of the created mesh and seed model 

Refer to the MeshTools 3D help for information on operating the utility. You may need to 
rotate the mesh to optimally view the seed body, but you may also need to adjust the 
threshold properties of viewing. These are controlled from the Options>CutOff menu item. 
Adjust the slider bars to suit the model’s magnetic susceptibility properties. 

 
Slider controls of MeshTools 3D to control the view of the body 

Step 5 

Return to ModelVision (you do not have to close down the MeshTools 3D utility). Select the 
UBC GUI button. Initially a UBC-GIF copyright notice is displayed followed by the main 
MAG3D interface dialog. 
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MAG3D interface dialog used to specify the model, data and inversion methodology 

For this tutorial, the main options are selected for you. The magnetics observation file is 
predetermined as are the settings for Data weighting and Wavelet compression. Refer to the 
UBC help for additional information on these settings. For fastest and optimal response, we 
recommend you select the computation Mode to be GCV and set the Initial model to be 
Default. The Mesh and Reference model can be left as defined. 

Step 6 

Once the above settings are specified, click the Save button (or the File>Save menu item). 
By default the control file selected is called MAG_INV.INP in the default directory. After the 
control input file is saved, the Run button becomes active. You can click the Run button and 
the inversion commences. 

The inversion is executed in a DOS window that presents the progress of the computations. 
You will find that inversions depending on the speed of the computer, available memory, 
model/data complexity and size vary considerably in time required for a solution. For this 
case, about half an hour on a 7-800 mHz machine is required. 

Note The UBC-GIF software is installed but has not been licensed, an error message is 
displayed. For more information, "Installing UBC Software" in the ModelVision User Guide 
PDF document. 

 
 

Step 7 

Once the inversion has completed, the output, inverted solution files are written and these 
are available for examination. The inverted mesh solution can be viewed in Discover PA 
(with Voxel Model option) or in the MeshTools 3D utility. 

In this case, the default file output is called: 

Model file – MAGINV3D.SUS 

Mesh file – MESH.DAT 
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MeshTools 3D representation of the output, inverted model 
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